Ank Liberty 2 Pro microphone not working

I’m trying to use my ear buds during calls, but the microphone seems to not work properly, every time I was in a call wasn’t able to speak as no one could hear me.
Did a simple test at home recording a voice message, and clearly the record sounds like if I was talking 200 mts away from the mic.
Is there something it can be done? or is a failure on the hardware? Already tried resetting them, but didn’t make a difference.

Kind regards

What device you connecting to?

If Android phone (you didn’t say!) then you’d delete pairing, turn off bluetooth, reboot phone to recovery, wipe cache (do not wipe data, that is a phone reset) , boot.

Buds follow the reset instructions noting to plug into power while resetting and also leave buds a minute after reset to ensure it’s completed.

Then try.

If doesn’t fix then go into your pairings and ensure it says used for calls. If so then do all the above again, to be sure.

If that doesn’t fix you’ve convincely showed your buds have issues and so open ticket with showing photos of serial number, photos of product, proof of purchase and write-up of fault and that you’ve tried reset multiple times.

Tell us the device you are connecting the buds to please.

This is happening with multiple devices, iphone 12 and mac book.

1 Like

The microphone not working may be related to it being connected to two things at once, one of them is in headphone mode which blocks the microphone.

Eliminate all possible causes, delete all pairings, and reset the buds then only pair with only your iPhone and then test. If mic not working then you’ve proved the buds are dud and email support for a warranty ticket. Good luck.

Note also if you were out of warranty, or you bought from one of those methods you cannot get a full refund without paying postage back, then if your microphone is physically bust you can force it to use the other microphone in the other bud by alternating which bud is taken out of the case first.

Thanks! I’ll try those steps, although the headphone is always connected to one device only (Didn’t know it could be connected to more than one at the same time).

Keep you posted if it works :slight_smile:

Same issue here! Are you already fixed?

I tried above steps and neither, definitely must be hardware issues :face_with_symbols_over_mouth:

same issue here too, I’m using iPhone 13 Pro Max and it was not working since the app had been updated few days ago.