Can't Connect Soundcore Space A40 to Google Pixel 4a

I just bought the Soundcore Space A40 and when I try to connect them to my phone via the app I get the follow message “Couldn’t pair with Soundcore Space A40 because of an incorrect PIN or p…”

When i try to connect via bluetooth I get “Can’t communicate with Soundcore Space A40”

not sure what to try next. I already reset the phone and the headphones and restarted the bluetooth on my phone. they will pair to my computer no problem

When you say you reset your phone, did you actually reboot it?

To be clear you never connect via the app. You pair bluetooth, then run the app and it connects automatically.

You need to do all of these steps:

  • uninstall the app
  • delete the pairing
  • reboot your Android phone to recovery, wipe the cache (not data)
  • boot phone
  • pair with the buds. This should now work
  • install the app, then run it, it should now connect to the buds.

How do i wipe the cache. i tried and i got a no command when i went into recovery mode

Every phone is a little different. Look for “wipe” or “erase” (don’t worry it will ask to confirm anything)

then look for wipe data or wipe cache. Never ever wipe data - that is a full phone reset - select wipe cache.

If you don’t want to use recovery to wipe cache a slightly more complicated but less risky approach is to disable bluetooth, then go to settings, apps, bluetooth, force stop, storage, clear cache, reboot.

I think I read that if your asked that question, put in 0000 (it was all 0’s).

Worse case would be contact All are sound points given

I ended up wiping my phone and starting over. that fixed it. i cleared the bluetooth settings and things got worse none of my bluetooth devices would repair. the clean install fixed everything.

Thanks everyone for your help

1 Like

You should not need to reset a phone to fix bluetooth issues. Normally just wiping cache accomplishes the same thing with much less effort.

My phone, for example, has never been reset and it’s over 4 years old and been used with dozen Soundcore products. It does get confused and a reboot fixes that usually, and sometimes a cache wipe is required, never a reset.

If none of the Bluetooth devices were working, I would have just restarted the phone before an install. A restart of the phone can fix some of those random issues at times. My son has had some beats 3 headphones losing BT but not a phone as of yet. I hope that is just a random glitch than the phone messing up.