Does anyone know if and when we will get a new firmware update for Sound core liberty 3 pro?

My Bluetooth connection keeps dropping off from time to time even if I am very close to the source with the earphones or sometimes it just plays one ear and the other keeps cutting off and then comes back later.

Any thoughts?


Best would be to contact the support.
They might know and give you a satisfying answer.

I would suggest to contact customer service by email

Firmware updates are rare for mature products, as all bugs fixed in first months. L3P released a year ago.

This issue is possibly a hardware failure so gather your serial number, proof of purchase, photos of product to prove not damaged, and be ready to email support to open warranty replacement ticket. Hopefully you bought direct / Amazon where you don’t have to pay return posting costs.

In the meantime you can try these tricks:

  • what can cause these cutouts is you have paired to multiple devices, of different bluetooth versions, one of them is older so bluetooth runs at an old inefficient version. To fix this cause, delete all pairings, reset the buds, then pair with just one device. Try that first.
  • your phone may be confused itself, so if the above doesn’t work then also if Android insert a cache wipe, so you’d delete pairing, reset buds, reboot phone to recovery mode, wipe cache, boot. If iPhone simply turn phone off, wait, on after delete pairing.
  • if neither above worked, then attach statements of all you’ve tried to fix, such as already done a reset twice, in the email to support as that helps save the mundane 2 day wait when they tell you to do reset (which you’ve already tried).

We would have no idea, but Support might be able to help you out.

I don’t know if anyone will find this interesting, but I had to send mine in for a warranty replacement.

After I received my new ones arrived, I got them set up, but LDAC was a separate firmware update. I don’t remember that being the case on the first set I had.

Anyways, now I’m on firmware 04.93. I can’t find anything about it online…

Matthew Garner, did you did intent to paste link to your google photos?

The L3P did have the enable LDAC to cause a firmware update.

I was just trying to copy and paste the photo. Didn’t realize it set it in Photos.

So 04.93 is the latest Firmware? Or just for the LDAC?

It’s always been like that. I think the Firmware is 3.XX for non-LDAC and 4.XX for LDAC.