Error when use Anker Soundcore Liberty Lite on Macbook Pro 2019

When I use headphones with MacBook I often hear noisy sounds (sound interference effect). It causes a lot of discomfort to my ears. Pls, is there any way to fix that issues? :pray:🥲

Does the same issue show up when the headphones are connected to another device?

I tried it on my phone and it didn’t happen so far

This can be caused by different apps, so try closing and trying various media players or apps to listen to your audio source…

If all else fails, try selecting your Bluetooth headphones again:

  1. Choose Apple () menu > System Preferences, then click Sound.
  2. Click Output.
  3. Select Internal Speakers in the list of devices, then reselect your Bluetooth headphones.

I tried it and the problem is still there, nothing has changed🥲

There was another thread that had a similar issue with the q35 or q30 with a mac but it was a crackling sound.

And how do you fix it?

May be you will find it by using the search function (Magnifier) upper right corner beside of your logo.

I can’t find it. Can u share that link for me, pls :pray:

As stated in other one, you have to eliminate potential issues . Try another device to see if with the phone or tablet, reset the headset.

Try to update BT drivers and or check app used or try a different app. Try wired or BT

There is no driver on MacBook, I’ve reset the headset but the issue is still not fixed :frowning:

Of course the are bt drivers installed on a Macbook.
Do some search by Google to find these for you OS-version and do an update!


I updated BT lasted ver, but the issue is still there. Maybe reinstall or update firmware for earphones can fix my issue. But I can’t find any updates firmware on google 🥲

Did you download the sounfcore app? If not, you can update the firmware from the app once you connect the device to the app.

Did you try the headset with an android or other Apple mobile device? If no try that then it may be just a mac issue and as @Tank stated an issue with the program. I would try as stated different programs as well.

Lastly, you can contact to see if they have received other calls on this and if they have a specific solutions

The Soundcore app doesn’t support Liberty Lite.
I don’t see this issue on my iPhone.

Sorry, I forgot those are not app supported. It looks similar to Liberty neos.