LA2P and new Soundcore app


Anyone with LA2P and new Soundcore app( I received update today) can check if fit test works for you…For me it always stuck in testing screen


1 Like

Don’t have these buds but in Android when app is stuck I close the app and sometimes have to go to settings, apps, and force stop, to kick it out of getting stuck.

1 Like

Not had this on mine, didn’t have the option when 1st received mine.

Maybe reset, unpair, & re-pair & re-connect?

1 Like

Yeah, I did that already three times. No luck…I waited for more than 5 min. I don’t think that will take more

Yes,I will try that…thanks

Just tried it now…no luck, still same :frowning:

Did you try uninstalling the app as well as unpair?

Just thinking you might want to remove an evidence of the earbuds & app, reboot the phone, then add the earbuds, and app.

Sorry, can’t think of anything else.

I forgot to mention that, I did all that steps.
No luck.l also reported it to the support, will see…


Clutching at straws but did you also try a phone reboot?

I will say it is interesting that they include a test for anc which is pretty cool


Which is broken atm it seems so

My fit test is working properly

Can you tell me what you got after those short sound in the beggining and how long did you wait ?

My fit test is working properly as well. Phone is Samsung Galaxy A71.

Just after the sound test with the “Testing” circle is complete it continues to this results screen with about a one second delay:

1 Like

Ok, I tried to repeat the fit test on my Lenovo Yoga Smart tablet with Android 10 (as is my Samsung Galaxy A71).

The circle isn’t animated as on my phone. It plays the sound and then nothing. It just hangs there.

Playback from eg. Youtube and controls are fine on the tablet. It is only the fit test that hangs.


Ok, thanks for testing…I will try with different phone. Maybe there is issues

1 Like

Android? Sometimes… an app is updated to need new permissions and you didn’t notice it. Right-click the Soundcore app icon and look for app info, or go to settings, applications, Soundcore. Then permissions. Look for any denied and allow them. Then force close app and try again.

Clutching at straws… but I do know Android. Sometimes an application is not allowing it’s permission requests to be placed over itself so you get a silent denial. That is Android version specific and why you might have an issue on one Android but not a different Android.


Thanks for notice, but I already tried that. Luckily I have a lot of experience with Android ,so I did all basic stuff…from reinstalling, factory reset headphones, reboot, permissions etc…I will try tmrw on android 10 ,maybe app is not updated yet to android 11

I tried with Galaxy A70, same case.The circle isn’t animated . It plays the sound and then nothing. It just hangs there.

I am out of clue what to do next

Mine does the same, I just got them today. Hopefully it’s just a bug they will squish in an update soon! It happens every time… Fit test is the only thing that doesn’t work.