Liberty 3 Pro Answer/End Call

I can’t figure out how to answer or end calls from the liberty 3 pro. Not in the app or anything I physically try. Am I missing something or does it not allow it? Other than that I love these buds, aside from LDAC killing the battery in less than 3 hours lol so I keep my Vista 2 for back up. About to purchase the Beast Fit Pro next. I’m addicted, but I need to answer the phone I’m a truck driver I can’t always reach for the phone. Any help is much appreciated.


Normally it’s pressing the play/pause button. On mine that’s pressing the Right Earbud’s Touch Pad twice (Double Tap). I’ll try and test it out today.

1 Like

I have the same question. I tried with play/pause button (tap once right earbud on my case), it just doesn’t work. Can’t answer and can’t end call.

1 Like

I actually have the opposite problem. My Pro 3’s end my call if I fumble around with them too much :-/ Any way I could turn off that feature?

I am having the same issue. It seems to answer sometimes, but not others. I haven’t been able to get it to answer with the left bud on only.

Also, is there a way for you to “hear” who is calling you, by speaking your contact entry? (Like my 10yr old Jawbone does)

I figured out mine was double tapping the left ear bud, but of course, make sure your hands are not too dry or it won’t recognise the double tap, and make sure you tap in the middle of the earbud. It would be nice of this showed up under Controls in the app, or in the help…

1 Like

Found this in the Quick Start Guide

1 Like

The issue is default multipoint headset profile response. What pleases one person - answer both - annoys another - don’t answer if already in a call.

The democratic answer is to make it a configurable setting toggle in the app. But given this is extremely niche doubt it will end up a priority.

The best suggestion is to email and make it a suggestion ask request and cross fingers.


For me, after some testing, I found out that a double tap on the left earbud answers a call, and a double tap on the right earbud ends a call.
I could not change these settings in the Soundcore app though. In the app, I can only change volume, play/pause, next, previous, voice assistant, and the transparency controls.

1 Like

That’s not exactly what the manual says. Manual wrong?

1 Like

Thank you for sharing the images. Gonna be honest here… The manual is correct. I was testing ‘blind’ so to speak, trying single, double tap and other controls to answer/end/reject calls. After more testing with the images from the manual, I got all the controls to work for me.

Gotta say I like these earbuds, very happy with them. Having said that, the phone controls are somewhat ‘buggy’. Answering/ending a call is a lot easier than rejecting a call. Additionally, when answering a call the ringing will sometimes continue after answering. Double-tapping and trying to answer again usually doesn’t end the call but might end the call accidentally.

Lastly, answering/ending and rejecting a call works with wearing just one of the earbuds left or right.

1 Like

I don’t have these (so wait for other owners to comment) but do have a reasonable recollection of owner comments and what you say I’ve not seen mentioned. Have you done all the firmware updates offered?

L3P is not really something those who make lots of calls buy, as they aren’t that comfortable as say LA2P or P3, so fewer owners mentioning call use, they are more commonly used for shear music enjoyment.

1 Like

I have firmware version 04.93 Additionally, these are my first BT earbuds and maybe I’m a bit too critical. My previous BT over-ear headset had physical buttons and I’m still getting used to the touch buttons.
I do want to mention another bug/issue. I used the buds for working from home last Friday. Not so much answering phone calls (only 2-3), but more for calling others. The buds disconnected twice mid-call… I have LDAC turned off by default.
My primary usage for my L3P is music and movies (had no issues with that so far), but I still want to use them regularly for phone calls as well.

1 Like

In general to get the most reliable call quality only ever pair with 1 device, it lightens the load on the buds and reduces overall chatter over Bluetooth channels.

These smaller in-buds also have a greater hurdle getting the Bluetooth signal out, particularly if the phone is on-person as the signal is passing through the human body. Stick buds have better external to the body antennas.

Try to keep Wifi on 5Ghz to reduce congestion on 2.4Ghz shared between Bluetooth and Wifi.

Keep the phone off-body, not touching, away from metal.

There’s also a lot to be said for not using buds for voice at all, just the phone’s mic. One less thing to hiccup. Just use buds to listen to things.

1 Like

Thank you for your information. I have paired my L3P buds with 2 phones, work and private, and my work laptop and personal Desktop. Is this a permanent problem or can I fix this by unpairing some devices and/or choosing the forget option?

I chose the L3P because of the multi-point connection ability. I like using them on all my devices. To improve call connection, should I just connect the to the one phone I’ll be using for multiple calls to avoid disconnects?

You mentioned, “smaller in-buds also have a greater hurdle getting the Bluetooth signal out”. I experienced really good range, the buds connected to my Desktop PC while parking my car and my apartment is 2 floors up. But is this just point-to-point connection range and this has nothing to do with disconnects during a call? My buds disconnected with my workphone (2-3 times) when it was on my desk in front of me.

Lastly, how do I set up “not using buds for voice at all, just the phone’s mic”
on my android phones? I only know how to do it on my work laptop and PC.

Thx in advance.

If the buds are paired with and connect with multiple devices, they then have more concurrent bluetooth connections and so must work harder, one of the channels will be less congested and if you use multiple connections necessarily at times one will be a weaker signal.

If you want the most reliable connection, just pair and connect with 1 device.

Nothing to do with this specific Soundcore product, just an implicit obvious issue with multipoint - it reduces reliability.

Put it another way.

At any particular moment, there is a best, least congested, Bluetooth channel (of the 79 available). You’d want that best channel to be solely for your phone call. But you didn’t. You made the buds use 2 channels (one to phone, one to other device) and so you’re making it more likely the phone call is not using the best channel.

To not use Bluetooth for a call is easy, during a call just change device from the buds to the phone.

Multipoint, adds convenience, but makes it less reliable.

1 Like

Thank you for your quick reply and all the information you have provided in previous comments.

So, in order to improve the best call quality and connectivity I should have the buds only connected to one phone/device while using them for calls or MS Teams meetings for example. I’ll test this next time I work from home or have to call multiple people or have multiple MS Team meetings planned.

“To not use Bluetooth for a call is easy, during a call just change device from the buds to the phone.” Figured out how to do this thank you. Not ideal though imo, because I want to use the buds mics, because they’re better, but I’ll test if this it makes the connection more reliable.

“Multipoint, adds convenience, but makes it less reliable.” This kinda sucks, but it also makes sense.

For other readers looking for an honest opinion about the Soundcore Liberty Pro 3 buds. I am still very, very happy with these buds. Sound quality is great while watching movies or listening to music (no need to use ‘high-quality’ audio codec LDAC imo) and they fit me comfortably (4 choices for tips and wings). ‘Normal’ call quality is also great. My issues were probably caused by the buds being connected to another device in addition to the device used for the phone call.

Thank you @The_Professor for you info.

1 Like