Liberty 4 battery not showing in iOS

I just purchased the Liberty 4 and so far I love them. I am having an odd issue that the battery life doesn’t always show up in my iOS battery widget. I reached out the Soundcore and did what they suggested, unpair/repair and get the soundcore widget but neither worked. The Soundcore iOS widget does nothing other then open the Soundcore app.

1 Like


I would wonder if clearing some of the cache and /or restarting the device if you have not done it in a while may help.

I’ve done both. Restarted my phone multiple times. Deleted and reinstalled the SC app and still not showing up in the battery widget. The SC widget is nothing. It doesn’t show anything. I tap on it and it only opens the SC app.

I can only see my battery on sound core app.
not on battery widget.
I was about to open a thread for this issue.

I have paired and unpaired 100 times re-install app etc.

another huge letdown.

1 Like

The L4 are nice earbuds with great sound and battery life. Very nice build quality too but unfortunately the software seems buggy/glitchy. For the money you can’t beat it. If I wanted perfect performance, I would have to go with Apple and pay twice as much

its not all about money.
I choose the liberty 4 over the apple pro 2 for the mic quality and the sound eq.
this product almost looks like beta.
nothing works 100% of the times as it should.
even answering calls. many missing features and many not working as they should.
hopefully they are working on the software.

Don’t have these but it’s been mentioned before their widget is not as well featured as some one like compared with the app.