Liberty Air 2 Connection stuttering - Suggestion


I have the Liberty Air 2 and so far I’m loving it. However, they face the same issue as multiple earbuds where the connection drops / stutters some times depending which pocket you have your cellphone in. This is because human body is a big source of interference and the Bluetooth antenna is basically stuck inside your head with this model design (the Pros, for example, stay outside due to it’s design).

The Airs 2 can work independently, however, when both are on, the right one is the master and the left one is the slave. So if I have my phone in my left pocket it cause the connection to drop.

I wanted to suggest to allow both earbuds to be able to sync with the phone or to allow us to choose which one is the master in the app. That way you could avoid this.

Thank you!

I’m assuming you’ve used the Soundcore app to update them to the latest firmware? I know a lot of times the phone companies issue an update and Bluetooth devices have to be updated as well to work seamlessly.

^^^ this. I had stuttering, but then I updated the firmware and it’s never happened again.

1 Like

Both earbuds and phone are up to date. I’ve also tested on another phone and same issue. My wife also have a pair of Air 2 and she also have the same issue.

What phone are you using? On my SamGalaxy S10e I can pair each earbud to my phone individually and you actually get better battery life that way. It’s called dual audio, you can enable it in the settings

One Plus 6T, and I believe it also has…but I don’t know if the phone allows me to override the earbuds protocol to assign master and slave…since you are saying you do it I will try.

So, i just tried to make left the master and apparently it works, but I need to disconnect right and connect left manually, then right becomes the slave. However, once I put them in the case and open it again, right is assigned as master again. So to have this done manually every time is not a solution.

Put the earbuds back Into the case and reset them. Then when you pair to your phone, make sure the right earbud is turned off and pair the left to your phone first. Then turn the left off and right on and pair the right earbud to your phone. They should both be individually paired and connect to your phone that way now

Thanks for the suggestion but it didn’t work.