Liberty Air 2 do not charge more than 60%

My new Liberty Air 2 got delivered today.
I am facing a weird issue.
The earbuds do not charge more than 60%.
I charged them for about 4-5 hours in the case as well
The case itself has about 90-100% charge
I tried a reset many times, but it does not help.
Nothing I do seems to help
Liberty Air 2 firmware 01.53

Does anyone have a solution on this?

I would try a different charger or cord to start.

Oh, I did that.
I tried a different cable
Then I tried a different charging brick.

It’s weird because it will charge from 0-60 no problem
But then it does not go above 60 at all.
This is with the case being at 100% charge.

If the buds can charge from 0-60 with no issues, they should technically charge above 60 too.

I am not sure what the problem is.

1 Like

is this you or just coincidence?

I’d challenge if you’re actually doing a reset, double down on the steps of resetting.

Once sure you have then it’s a support ticket.

Haha, that is me.

-I did a reset as well. Waited for the 3 red lights blinking on the buds (that’s when I know the reset is complete)

  • I connected with 2 different phones, an iPhone X and an Android

I am not sure if I am doing something wrong.

For my next step, I am going to try and charge them with the lid open because I have read that for some people it is only charging with the case lid open.

I’ll try reset again, double down on it as you say
If that doesn’t help either then a ticket is the only option left.

The retailer is offering a replacement you said…

So you have these and another new set.

The retailer (Flipkart here in India) delivered a new set today.
However it is from the same batch (Manufactured in November 2020)
They took the previous one and gave the new one as replacement.
However, the since they are from the same batch, they are showing the same issue
The first thing I did was I did not connect them when I got them out, I charged them for good 3 hours
But still the buds show 60%

So either it is an issue with that batch or an issue with the firmware version of the buds that I have. (That is what I think)

Refer to image below, Replacement delivered on 3rd May.

So if replacement does exactly the same, it’s more likely to be not a hardware fault, as for example it would not be 60% but something else (50% 70% etc).

Scratching head of you’ve done all the usual things of reset everything.

I think this has to be a defeat for me and wait for support to give answer, when you get it reply here as chances are someone else will be asking soon.


Yes, it is definitely not a hardware fault for sure.
It is more of a software issue I feel.
And I think it’s more prominent in the buds with firmware 1.53

All the things have been done, now I’m just going to leave the case open and let them charge with lid open.

Anyway, @The_Professor, I appreciate your help.
You sacrifice won’t be forgotten, soldier.

Just needed to ask, do the people from Soundcore reply here or it’s better I draft an email to them?
Just new here, so I’m not sure if they’ll reply

Anecdotally just from observing, I see official support here reply a few hours to a few days later, but it’s far better, and the reply will say also, to email support. Proof of purchase, serial number and some description required.

Community support complements in that if it’s a common well known issue with fix, we often can fix it here between peers than official support, but this one of yours not remember seeing it before so its random “try this try that” until official support reply.

As it is two bud sets did the exact same, it is probably not the buds themselves (might be but chance two have identical issue should be low) so shift focus to the phone and the app.

When it says 60% is it your Android bluetooth notifications settings showing it or the app?

Try all of this:

  • buds in case, plug case into power, leave overnight.
  • buds out, buds let them do any firmware upgrade(s) as you’ll be asked if you have already.
  • uninstall the app (that you needed for the buds to do upgrades)
  • delete the pairings
  • turn off bluetooth
  • delete cache (recovery, wipe cache, boot, OR settings, apps, show system, bluetooth, force stop, clear cache, reboot)
  • pair (take right bud out, pair, accept the L bud pair)
  • install the app, connect in the app

See what’s different.

Also nose around in your phone’s forums for mis-reading battery percentages, it may be an issue of your phone. It could just be an issue with your phone these buds are triggering. Explore both avenues until hit bedrock.


I kept them for charging with the lid open.
To my surprise they charge till 100% but only with the lid open

If I keep them in the case with lid closed, they will charge to 60% only

Also regarding the charge readings
Both iOS and Android show the charge remaining in the buds natively
Android shows in the Bluetooth settings
iOS shows in it’s left most pane/window.
And both the charge readings were identical which means the buds do have that limited charge.

Also will try the bullet points that you have mentioned to see if that fixes the issue.
More and more it seems like a firmware bug in 1.53

1 Like

Thanks for the update. That’s weird.

I agree with it being something other than earbuds and think the delete of the cache is an excellent reason for the issue.

Soundcore pushed a new update for the Liberty Air 2 today
The firmware has been updated to 1.63
The changelog mentioned “Bug Fixes”


Now show if charging closed case solves 60% charged problem.

Thank you guys, this has been really helpful.Recently bought liberty air 2 and had the same issue. The firmware update seems to have resolved it. However I noticed that if I do not explicitly disconnect my earbuds before placing them in the case , they dont get charged. They do disconnect from my phone on closing the case but simply don’t start charging. I left them in case for couple of hours and they remained at same battery level. On some experimenting I found that they charge if I explicitly disconnect them . Is this something that is happening with everyone or do I have a defective piece ?

Hi @deepanshu.shah

Glad to know that I am not the only one facing issues with my buds.
The 1.63 firmware seems to have helped a lot with respect to charging.

Regarding the above issue that you are facing, I have noticed that when I connect my buds to the phone after charging, they show the last percentage I kept them in the case at.
Let’s just say I kept them in the case at 80%, and after an hour if I connect them again, they start off by showing 80%
The buds show 100% only after I open the app and complete the sync.
I am very positive that your buds are NOT defective but the software is a little buggy as of now.

Try it and let me know.

Hi @The_Professor

The firmware update to 1.63 has helped the buds massively.
Now they do charge.
As suspected it turned out to be a software bug.

There are still one or two small bugs, but nothing huge.
Overall very happy with the buds that I have.


Thanks for the update.

So the workaround of charging with case open not now needed?

Now you DO NOT need to keep the lid of the charging case open for them to charge.

They charge as they should do normally.