Liberty Air 2 multiple issues

Hello! My name is Seth! I purchased the Liberty Air 2 yesterday through a retailer in Hungary.

The product sounds good and I love it but I have two issues, for which I did not find any way to fix it.

  1. I cannot update the firmware. I have tried everything said in the tips webpage, also I looked through the forum. It starts the update process, but it fails after a while. I tried multiple times. Sometimes it fails after 70%, sometimes it fails at around 50%. I even tried disconnecting my Bluetooth watch as well, I thought that might interfere with the update. I tried moving into another room to further reduce interference. I even tried pairing the buds to an iOS device and starting the update there, but the same thing happens. After a while, it fails the upgrade procedure. I did the whole unpair, reset, repair procedure multiple times and nothing helped. Actually, this wouldn’t be much problem, but I thought this might cause the second problem which is:
  2. My right earbud does not last 7 hours as the left one. I actually recharged the buds two times and listened to music while working, all day. I started at around 10 AM, both being 100%. Then at 3 PM, the right bud died, while the left still can go for two more hours at least. I wouldn’t mind if the gap wouldn’t be so massive, but 2 hours difference is huge. So that is why I thought upgrading the firmware, to see if this fixes my problem.

So I thought I’ll ask you guys if there is a way to fix these issues, if not, I think I’ll be returning these. Even though I love how they sound and they are comfortable, this 2 hour gap in battery life is unacceptable, at least for me.

Thank you for your time, have a nice day!

I think you should contact support about this, as you’ve pretty much exhausted all that you could try doing yourself.

1 Like

Thank you for replying! I contacted support on Friday so that’s understandable they did not respond yet, but we’ll see what’s going to happen. I would rather not return these if there is a fix for it, but this battery problem is really concerning…

I doubt it’s a software issue (especially the battery problem) so… you’d probably have to get them replaced. :confused: Hope I’m wrong. Troublesome otherwise.