Liberty Air 2 Pro microphone not working in Teams

Hello all,

I have just purchased a pair of Liberty Air 2 Pros, they work great with iphone. The earphones work well in Teams but the microphone doesn’t work at all. I have the right devices set up and have run windows troubleshooter on the device. No luck any help really appreciated

Ben.
Picture1

I don’t have Windows 10 but I can read others’ posts and repeat back. If I’m wrong then useful thread at least.

You cannot solve this problem.

Windows 10 either uses headphone (stereo, high quality, no microphone) or headset (mono, lower quality, microphone) for bluetooth. It cannot run these in parallel concurrently (unlike say Android or as you claim your iphone can).

Different issues like poor audio quality can be improved with updating drivers (delete device, search).

The workarounds are:

  • ditch Windows 10.
  • Use Windows 10 and phone (e.g. Android) concurrently in parallel, one for big screen, keyboard, other for audio
  • Use the Windows 10 machine microphone built-in, and bluetooth for sound. This keeps bluetooth in headphone mode at least.

If anyone else has better for this situation then I’ll read and try to understand and remember.

I do wish all these threads were retitled “Windows 10 xxxx” to help searching as many, many, come here thinking it’s a Soundcore issue.

Thanks Prof, very useful.

I did have one teams call which started fine, then the audio went “underwater” but with microphone still fine. After that call only audio working. Do you have any further idea what might be going on?

Thank you,

Ben.

One thing you can try and has worked for others is to switch your computer to use the 5Ghz wifi connection and it won’t interfere with the Bluetooth connection as it operates on the 2.4ghz frequency. Once you do this, try These suggestions

Hmm this is interesting. You can try 3 things here to see what is the issue here:

  1. To check if MS Teams is the issue, try to open a camera app and see if you can use your LA2P mic to record video
  2. To check if LA2P is the issue, try to use your Surface mic and see if the mic input level increases
  3. To check if Windows/MS Teams is the issue, you should go to Settings and see if MS Teams is allowed to use mic under privacy settings

Seems like a MS Teams problem from a google search but better to rule out stuff and reach the correct customer support

Thanks Shivam_Shah,

  1. I was able to use the LA2P to dictate to word
  2. I was able to use the Surface mic
  3. the mic is available in privacy

I removed the headphones from bluetooth in windows, reset the headphone and re-connected, all of which I had done yesterday to no effect, but this time it works again.

So no idea what the problem is/ was. I am grateful for your suggestions and help - thank you

Ben.

1 Like

I am happy to say the call quality now seems very good. Listener cant hear coffee machines and drills near me but can here me well. Teams/ Liberty Air 2 Pro now playing well together. Some driver updates/ Teams updates that I had nothing to do with seem to have solved the problem

2 Likes

Hi Ben865,

Could you please tell me how this problem solved because I still suffering from it?
I am appreciative of your suggestions and help.

Best regards,
Osama

Osama,

I’m sorry but I don’t know how the problem was solved. I have updated Teams and Windows as well as firmware on the buds. I think it was an update to Teams but am not sure.

Ben.