Liberty Air 2 Pro - no multipoint

I recently upgraded computers, so now my Dell laptop and Galaxy S9 both support Bluetooth 5.0. Which should have been an upgrade, as the old computer only went up to Bluetooth 4.1, and strange things could happen based on which device paired first.

I know I used some over ear headphones (Q30 in particular) with both the computer and phone simultaneously. But I am almost certain I was doing the same with the Liberty Air 2 Pros, and have not been able to get that working since. Came on here to look for answers as well as doing some research, and here is what I have found so far:
Multipoint is not supported on the Air 2 Pro per this support article:
The instructions have directions for pairing with multiple devices (user manual). It may be that is only to use them by disconnecting from the other device, because it doesn’t seem to work any other way. But certainly confusing.

Did this ever work? Am I just misremembering? Only switched computers mid december - and it didn’t work right after that, but no time to troubleshoot at the time with the holidays coming. So now trying to see if I was just wrong, or if there is another way to set these up that will work, or if it was available at one point and then removed for some reason.

Any help making this work, or confirmations that it never has, would be appreciated. Or any soundcore people, is this planned to be added? These are the most convenient to carry earbuds I have, but might have to go back to over ear for the convenience of that feature.

1 Like

I’ve probably not had mine as long as you (just about a month) but was looking for that feature prior to purchasing these (maybe L3Pro has this). I read specs that multipoint was not possible but for me it wasn’t that important so I bought them anyway.

When going from my PC to phone for example, I have to disconnect them from PC and then go into Bluetooth on my phone to reconnect them there or vice versa. For me it’s not a big deal as these are the best wireless or wired buds I’ve owned hands down.

Not much help but my experience is similar to yours.

1 Like

The LA2P Do Not support Multi-Point.

The L3P Do Support Multi-Point. They are the only Soundcore Earbuds that do. As a matter of fact Multi-Point is pretty rare in Earbuds, regardless of the manufacturer.

A few of the headphones do have Multi-Point, but when it comes to Earbuds, only the L3P do.


Somewhat agree. Although q10 or 20 did not have but think somebody found you could sort of get it to work . I have tended to use on one device so, I have not messed with mine that much…

1 Like

Depends if you are fussy about having both earbuds w/ same sound source.

While not truly multipoint. You can bodge together each earbud to a different device. Downside being when not connected to the phone or laptop as source (not using) the earbud would be dead air.

I’ll see if I can find my method posted some time back, and edit it in.



The Q30s definitely have it, and I must have gotten something confused there. It is such a good feature that I am surprised they didn’t put it into these earbuds, it would be a significant upgrade for me.


Hi @jercox we’ve been on the Anker forum together for years, and surprised you need help :open_mouth:

No these don’t support multipoint but do you really need it? There has been across all Soundcore products a poor man’s way to get close to it.

Your phone can be paired for calls only, using the handsfree profile, and laptop can be paired for headphone profile. The microphone cannot be used with headphone profile. So this poor man’s method doesn’t work if you need to use laptop involving the mic and connected to phone for calls.

In your phone bluetooth connection, disable for media and contact sharing and have it only for calls.

Another workaround is to pair one bud each to laptop and phone. The tricky consequence is then you have to usually reset and delete all pairings to get them back to a stereo pair.


Ever have the feeling that something used to work, now doesn’t, but you can’t find proof it ever worked? Posted with that feeling to make sure the research I was doing was right, and I hadn’t missed something. Like a firmware update that removed the feature because it was buggy or something like that.

Thanks for the workarounds - had seen similar and felt that disconnecting one device and reconnecting on the other would be better for my uses. Multipoint would be much better than either.


If I’ve not forgot or misremembered myself, my recollection suggests you probably either misremembered or the accidental workaround worked for you. There’s been no threads of it being a withdrawn feature. The only withdrawn feature I saw was Q30 ANC wired, and added feature of LDAC to LA2P.

I’d be guarded against spending a significant amount of your money on multipoint products. There’s plenty of threads where it doesn’t work. All but one of my devices are on BT 5.0 so works well for me but not when swapping with my laptop BT 4.2, as you said you are swapping between BT 5.0 should work for you but even then there’s threads where Windows is greedy and won’t share. I can probably find recent threads to illustrate.

1 Like