Liberty air2 update not working

Updating goes to 70% then said error please help

I would say open the case and have them near to the device when you are updating them.

My only other thought is I know some areas where I live will slow down at different parts of the day. So if you do have a hiccup it could cause the download to fail potentially.

If your wifi is old, you want to try to do it close to wifi or go to a different location to try to download it.

Just a few thought

1 Like

Sadely nothig works also tried on my IPhone, same result
I do see that the right earbud has the new software the left does not.

Now buying another pair of Soundcore liberty air 2’s direct from Anker, The firmware does upload now, so it seems I bought a pair of fake Soundcore buds, no difference in pakking or contents. But the fake buds sound better and have in ear sensors, so they stop playing if you take them out, something the originals do not do.
Also the “fake” buds work fine with the app, just do not install Firmware

1 Like