Liberty Pro 2 right bud will not connect

Just received mine and the right earbud will not connect to Bluetooth. It does have power. I can’t find a way to fix it. Can anyone help? Thanks.

1 Like

Put both earbuds back in the case, press the circle button on the backside of the case. Hold it down for 10 to 15 seconds. Once done remove the right and left earbud and pair to your phone…there will be two profiles that pop up, one says liberty 2 pro and another that says liberty 2 pro L, you want to pair to both profiles in order to be able to use together or in mono mode

2 Likes

Thanks. Both are now connected but I can only choose left or right. Also the sound of the right one is about a quarter of the left one!

When you remove them both it should auto connect to each other. With the right earbud connecting to the phone as the main and the left syncs to the right. You shouldn’t have to choose any connection, just remove them from the case and let it pair itself.

As for the lower volume, I cannot say. But maybe its a setting in your phone?

Not connecting to each other. I can choose left or right in Bluetooth connections but can only have one at time. Straight out of the case only left connects.

In Soundcore app it says “connect both sides of device to explore all features” but I can’t.

(Volume was just a levels thing though.”)

Sounds like I may have a dud. Have removed and reconnected 3 times.

I have a similar issue

I had a similar problem where the right ear would power down when not is use and I had to manually power up. Then they had a new firmware update and the right ear failed multiple times. Anker support had me do the firmware while in the case and that worked. Now the right ear is fine.

Make sure you have the latest firmware.

1 Like

Thanks. I can’t see that there is a Mac firmware uploader yet but also I can’t see that there is a new firmware for the Liberty Pro 2 on the firmware update page here?

https://www.soundcore.com/update-firmware

That updater won’t update the firmware on the Liberty 2 Pro’s, it’s only for the speakers, the app for your phone is the one that updates the buds

The app on the phone just says connect both devices. Whatever I do I can only get sound out of one earbud at a time. I’ve requested a return.

I ran into the same issue and they’re going to send me a new pair. I love these and the sound is incredible. I’m sure that there is nothing wrong with them physically. It’s just a bad firmware build but they’ve since turned off the firmware update part on their iOS app because they were running into so many issues like this one. So they prefer to get these back and send us new units. Kudos to their support. They’ve been amazing.

Yes problems can happen with new technology products. It is how they are dealt with and Anker have agreed to swap out and cover the reasonable return postage. Can’t ask for more than that. Looking forward to trying a working pair and comparing against my Jabra 65t.

I have my replacement set, thank you Anker UK for the great service, and they connected up fine, both now work. I have put the large buds and wings on and they fit well and are comfortable. A firmware update installed without issue as well.

First impressions are they sound good, different to my Jabra 65T, not sure which I prefer yet. I think the Liberty Pro 2 have the potential to sound better, if the EQ could be tweaked to a personal setting in the app. HOWEVER they are a lot quieter than the 65T at maximum volume which is frustrating with some songs.

Will try and set up the volume controls on the buds next instead of Siri.

I just had this issue, but I got it fixed. For anyone in the future here is what I did.
I unpaired the earbuds from the my phone, and put them back in the case. I did not close the case, and I held down the circle button on the back until the earbuds had a red led flash. After this I repaired to my phone and both are playing simultaneously.

5 Likes

Pressing the button on the back with the case open made all the difference. I’d been doing it with the case closed and was about to request a return. Thanks hobocat76!

How to fix

  1. Unpair both headphones from your device.
  2. Put both earbuds in the case. DO NOT CLOSE THE CASE!
  3. Press and hold the button on the button on the back of the charging case until the LEDs on both earbuds flash red.
  4. Take the headphones out of the case an reconnect them to your device.
2 Likes

Thank you for this. It worked. I was getting pretty mad. I love these buds and didn’t want to return them if I didn’t have to.

thanks everyone! This fixed my problem.

Worked great thanks