Life Dot 3i not found in Soundcore App (using Samsung A52s)

Hi,

So my Life Dot 3i pairs up and connects via Bluetooth no problem. I can play spotify and hear it through the buds. But when I download the Soundcore App and tried to Add My Device, it cannot find it. I have tried deleting all other Bluetooth devices, making sure the buds are the only one detected and paired, and still no success. I have tried uninstalling, deleting cache, and redoing the whole process, no success. I have tried as well to make sure I start the App first before even pairing the buds, still no success.

But when I tried it on Pixel 3A, the Soundcore App immediately picked it up.

I’ve seen other people raising similar issues here on Samsung devices, so it seems that the issue is with Samsung’s firmware. But the solution presented in the other threads are not working for me.

Please help if anyone knows the solution. And I think Anker should also reach out to Samsung and work this out. Both are well-known brands with huge user base, I find it weird that something like this happens for a long time with no permanent solution. After this experience, I will have to avoid using Soundcore stuffs for as long as I’m still using Samsung phones.

Thanks in advance!

Have you yet tried toggling A2DP offload in Developer Mode settings?

To make it connect in the app you must also have SPP bluetooth connection. Anything in the Samsung phone which interferes with a SPP profile will thus defeat the app connection. The A2DP offload engine toggle is obviously not SPP so usually Samsung phones refuse to bluetooth connect.

Soundcore is not doing anything particularly unique, all they are using is SPP for their app. Anything Samsung is doing to interfere with SPP will block all brands using SPP, meaning your Samsung phone won’t work with many brands until you research and find a Samsung fix for SPP.

I have just tried turning off A2DP offload in Developer Options. Soundcore App still can’t find my buds.

The thing is, the bluetooth is already connected. It’s the Soundcore App that can’t find the buds. I can use the buds with the phone no problem, I can use it for calls, I can listen to music, etc. I just can’t add the buds into the Soundcore App.

Thanks for your response. I guess Samsung users are being pushed into buying Galaxy Buds then.

You should contact the support.
May be they find one there who will check thiis

Strange issue. Seems the problem is at Samsungs end.
Did you granted all permissions required from Soundvore APP?

Where can I contact Support? I tried the live chat, but it says no agent is available at the moment.

Yes, I did grant all permissions for the App.

Fully agree that the issue is at Samsung’s end, because I had no issue with the Pixel 3A. I just can’t fathom how this could happen considering that these are 2 major brands we’re talking about. This is not chi-fi TWS with doubtful APK etc.

The best way to contact support is to send an email to service@soundcore.com
Probably live chat isn’t available because it’s a weekend.

No.

Your phone’s Bluetooth stack is not connecting SPP.

Bluetooth is comprised of the physical transport layer (radio), the negotiation protocol (4, 4.1 … 5.3), and then profiles (A2DP, AVRCP, HFP, SPP)…

Example from my Soundcore headphones

Soundcore is not doing anything unique, every other audio brand which uses SPP (for firmware updates or other controls) would not work on your Samsung phone so long as your phone is not supported SPP.

So the answer to the problem would be in a Samsung forum where someone (with any brand of audio) has a control problem.

I’d nose around in the Soundcore app permissions see if Samsung’s version of Android is doing something weird.

1 Like