Life Q30 does not work with Ubuntu 20.04

Hello!

My brand new Life Q30 does not work with Ubuntu 20.04. It is discovered as a bluetooth device but when I try to connect it does not connect. I tried with multiple computers, but it’s the same. I had a Q20 as well, it worked fine with the same computers and OS. The Q30 updated to the latest (01.90) firmware and I already tried reset and repairing.

Ubuntu has the 5.8.0-40-generic #45~20.04.1 kernel and bluez 5.53.
I can provide other information if needed and would appreciate any suggestions to resolve this.

Does anyone have the same problem?

Works for me same Linux same package.

If say it’s awkward, I have to connect to Linux first, if it’s connected to anything else first then will not connect to Linux.

Turn off all Bluetooth of anything else Q30 been paired with. Then connect to Linux. Then connect to one other item like Android.

I think it’s s version issue of profiles.

2 Likes

Thanks, for the heads up! I managed to make it work with one of my machines. Yes, it has to connect first, that was the problem.

1 Like

I believe it is related to the version of profiles, the multiconnect requires same version and Linux cannot do same version as other devices. A2DP is 1.3.2 I think Linux is stuck at older.

Or, It could just be that Linux hardware is 4.2 and your other devices are 5 and the headphones cannot do both 4.2 and 5 so if the Linux connect at 4.2 then the phone can connect at 4.2 but if phone connection is 5 then Linux cannot do 5 and so stuck.

What makes me think it’s the profile version is my Android phone is 5 and my Android tablet is 4.2 and they work no matter which sequence I connect. They probably have the same A2DP profile version despite different BT version

The chipset in Q30 is low end and so I think it’s implementation cannot multiconnect different versions.

Any update on this one ? I had it working on my laptop running Ubuntu 20.4.3 with bluez 5.53 but it stopped yesterday, I tried to factory reset without success…

Reboot the Linux system.

Hello,

I have the same problem. A brand new Life Q30. Ubuntu 20.04.03 and bluez 5.53. It is discovered as bluetooth device. I can see it in the audio settings, but only as output device. As input device (microphone), I can’t see it. Connected only on my PC and the laptop rebooted.

After some tests with my laptop, I connected it to my phone just to verify that the headphones is fully funcional. And it works…

Do you have some suggestion or I have to return it to Amazon?

Thanks

There are a lot of workarounds to be found to get “deeper” into bt configurations under Linux.

Try first this :
sudo apt-get install pavucontrol

and take a look on the inputs you can do there.

To explain all about LInux and bt would be beyond the scope. Sorry
So learning by doing, please, :smile:

`

1 Like

In sound settings change device from headphone to headset, then the mic option exists. Audio quality drops.

1 Like

Hello,

I solved replacing PulseAudio with Pipewire: https://askubuntu.com/questions/1339765/replacing-pulseaudio-with-pipewire-in-ubuntu-20-04

After that I can see and use the headset but the quality drops. Output is available only in mono.

If you want to listen music, you need the change the profile in audio settings

3 Likes

You did some search and were lucky to solve the problem.
Perfect!

Hi, I bought it to use while working, mostly to use it for noise cancelling , my machine is same, i had a little difficulty connecting first, but then i read on the manual it says turn off the device(Q30) then press the power button for 5 sec until the light flashes, but the light will flash before like after 3 sec but you keep it pressed for 5 sec then connect form your ubuntu machine it will work.

thanks for the reply

Thank you sudo apt-get install pavucontrol solved my issue and hours of time :heart::heart::heart:

1 Like

I have another suggestion for you!:grin:

Install PulseEffects.
The best audio tool ever.
You can play around with for hours and even after that you haven’t detected all its possibilities.

1 Like