Life Q30 (FW 1.80) power off by itself when on calling mode / using mic

Product: Soundcore Life Q30 headphone (Firmware ver. 1.80)
Connected device: Android 10 (OnePlus 5)

Normally the music plays fine, but whenever I try to use it for calling (or any application that attempts to use the Bluetooth mic), the headphone becomes unresponsive for 15-30 seconds, and then it straightaway turns off by itself, not even playing the shutdown music.
Microphone mode/ calling mode was working fine until FW 1.70. Today I received FW 1.80 update, and I was excited as it was supposed to solve the bad call quality issue, but on the contrary, the mic is now totally unusable when connected to my phone.

However, not everything is bad. I can use the headphone without any issue with my Laptop, Samsung (android) Tablet, and iPad, and the call quality issue is indeed solved. But surprisingly the issue is happening with my OnePlus 5 mobile device.

Things I tried to fix:

  • deleted Bluetooth profile and re-paired the headphone with my mobile.
  • Have reset the headphone by pressing the volume+power button
  • wiped cache on my mobile
  • of course, restarted my mobile and headphone several times

I have tested other Bluetooth earbuds’ microphone with my mobile and it works absolutely fine, so the issue has to do with the new FW 1.80 of Life Q30.


I tested it with iPhone and Android phone. As far as I can say, it works as expected (designed?). Music is paused, call is taken, after hang up music starts playing again (1 second?).

Thanks for your response.
I agree this is the expected behavior, but that is not what I am getting on my mobile, after the firmware upgrade of Q30.
The moment it tried to switch to calling mode (i.e any app using microphone), the headphone becomes unresponsive for 15-30seconds and powers off by itself. Then the only option is to manually power it back on. If I again try using the mic, it again powers off.

Maybe this is specific to some devices only? OnePlus maybe? But any case this new, and only happening after FW 1.80

Is the laptop you paired with have it’s Bluetooth on and in range?

You may have the laptop interfere with the phone call.

Okay, now I tested after turning off the laptop and all other paired devices except my phone. But still, exactly the same issue.

Don’t hold out hope, it’s just a theory of mine so ignore if too difficult.

Delete all pairings ever made with the Q30, including the laptop. Turn off all Bluetooth or just go far away. Reset the headphones. Only pair with your phone and not with anything else. Then see if the problem persists with your phone.

My theory is the laptop is causing the issues so eliminate it. The microphone improvement in 1.8 is using headphones setting but laptop force headset setting which then fights and so causes the issue.

I’m probably wrong so up to you.

On the headphones in the BT area, is the call audio and media audio both turned on. If yes, I wonder if turning off the media audio will allow it to answer the call without turning it off.

I was wondering if the audio was conflicting with the mic mode.

Thanks for the suggestions.
Although I did this already but did it again to be sure. Unpaired all devices, rest the headphone using volume+power buttons. Turned off Bluetooth for all devices I have. Then only paired with the phone and tried mic/calling. But, unfortunately exactly the same issue.

I have already tried this too. “Media audio” turned on or off, “HD Audio: AAC” turned or off. But nothing helped.


In this case your best bet would be to contact support so they know about the issue and help you out some other way. Could very well be a firmware issue that isn’t working well with your Oneplus

1 Like

Good troubleshooting so far, some great ideas and it sounds like you have worked through them. Definitely time for support.

I love new products, but one of the side benefits is that you get to be a beta tester at times. That is why they never rush new firmware, or make promises on timing. Sounds like you got caught in an edge case.

1 Like

Thanks for all your suggestions. I will email support now and will update here when it gets solved.


I can confirm this issue. The headphones turn off as soon as a voice connection is established in Microsoft Teams.

Detected with MacBook Pro Mid 2014, macOS Catalina.

The bug was not there before I upgraded to firmware version 1.80 (did not try with 1.70).

1 Like

Ok formalise it via opening ticket with Soundcore support. That appears the best way to get attention. Remember to tell them all you’ve tried already so they don’t tell you the obvious like did you repair, reset.

Also keep track here via keeping in one thread ideally.

1 Like

Same problem here, with my macbook pro mid 2012 Catalina. I try to connect my Q30 whit other macbook 2019 Catalina, and it don’t have the power off problem. Just with the mid 2012.
I have no idea what to do.

I do not have a macbook but if the 2012 is powering off, I am wondering if it is more of a Bluetooth issue. What is the Bluetooth version of the 2012.

As a guess, I wonder if it that is causing the issue per say.

Now I was messing around mic settings (input) on audio configuration, and just when I go to the input preference, the Q30 power off by itself.
Maybe that confirm that is a mic problem, because I can listen audio whit not problem at all.

I did the same, and will let you know what they answer me.
Good luck!

I have a Macbook Pro Mid 2012, and I believe it uses Bluetooth version 4.0

I am flowing this out in my head but you may want to check with if Bluetooth version 4 able to work with Q30.

Since Covid a lot of folks have bought Soundcore headphones. One of the biggest issue is the PC bluetooth.
So the first thing, you probably will need to do is update the Bluetooth driver if you have not.

There should be a cog on the Bluetooth for the headset (or it is on others devices). One option should be like mic and stereo (unsure of the name) If both are on, it may be trying to connect to one than the other. So turn off the stereo if you are using the mic part and see if it will not turn you off…

Other than those two, I would suggest to contact support for the 4.0 Bluetooth and connectivity to the q30.

There is definitely incompatibility with some Bluetooths, but I doubt Bluetooth version is the main issue.
These are the devices I have been able to test myself. OnePlus 5 has BT v5.0, but still, it does not work, while other devices, having either BT version 4.2 or 5.0 are working fine.

Device Bluetooth version Q30 mic works?
OnePlus 5 phone 5.0 No
Dell 55530 precession laptop 5.0 Yes
iPad 7th gen 4.2 Yes
Fire Tablet 9th gen 4.2 Yes
Galaxy Tab S6 lite 5.0 yes


If I may also add reported issues by @mha123 and @juanla

Device Bluetooth version Q30 mic works?
MacBook 2014 4.0 No
MacBook 2012 4.0 No


Last week, I contacted Soundcore support regarding this, they couldn’t offer me a solution at this moment, instead, they provided me the option to either return the headphone or accept a partial refund. I didn’t want to return, as apart from this mic issue I am quite happy with the sound quality, and also the mic is at least working with my laptop.
Just keeping my finger crossed and hoping in future firmware updates this might get fixed.