New q35s are randomly choppy while connected to my phone

Hey everyone,

I got a pair of Anker q35s a couple of days ago and they sound amazing! The only problem I’ve noticed is that while I’m using them with my phone (pixel 5) they’ll all of a sudden become super choppy, like cutting out every second. And it will last until I restart something, like the app, my phone or the headphones themselves, sometimes hitting pause/play on the headphones themselves will work. Even then it doesn’t always solve the problem, it’s pretty hit and miss, sometimes I just have to wait it out.

It doesn’t seem to have anything with obstruction because it can happen literally while I’m lying in bed with my phone in my hands. It also doesn’t seem to matter where I am in my house when it comes to wifi coverage. I’ve tried downloading the music on Spotify as well to see if it’s a streaming thing, and that doesn’t seem to matter either. It’s weird, they’ll be fine for like 20 minutes and then they’ll all of a sudden start getting super choppy, like right in the middle of a song or a video.

I don’t know if it’s my phone or the headphones, but I’ve never had this with my other Bluetooth headphones.

So I just thought I would check with you guys to see if you had any advice, otherwise I might just exchange them.


1 Like

I don’t suppose you have tried un-pairing and re-pairing again? Also, have you made sure that the firmware is up to date. Just a couple of things to try in the first instance.


Do you have the wear detection turned on? If so, I’d try turning it off and see if that solves your problem.


This could be a multipoint Bluetooth version issue.

Cause: These headphones allow to connect to two things at once, but it will become the bluetooth version of the first connected. As you move around one connected device is disconnected and reconnects, so causes a random bluetooth version change.

Sympton: your paired devices are different bluetooth versions so at a random time you are disconnnecting and reconnecting and the bluetooth version changes which is the choppiness you experience.

Cure: delete all pairings, reset the headphones, pair with only one thing. Stop, don’t pair anything else. See if issue resolved.


First I would delete the headphones totally from all your devices you connected them.
Then do a resetting of the headphones.
Then connect them to one device while the other is switched off.
If all works fine you can connect them to the other one an see whats happening.


Appreciate the reply, and I have tried un-pairing and re-pairing, I’ve also tried doing a full reset of the headphones, but it doesn’t seem to help. I have narrowed down the cause though and seems to have something to do with being dual connected to both my laptop and phone. After about 20 minutes they start cutting in and out and what fixes it is when I disconnect them from my laptop. I’ve contacted support about it though, so hopefully it’s something that can be fixed as dual boot was a pretty big selling point for me.

1 Like

I’ve tried doing what you suggested and it didn’t seem to help. But as you were suggesting the issue does seem to be with when I connect them to a second device, like my laptop. When I have them connected to both I get the choppiness, but then when I disconnect them from my laptop, it’s fixed. Not sure what to do about that, but I’ve contacted support as well, so we’ll see.

1 Like

I think you’re right, being paired to only one device at a time does seem to fix it. But that being said, a big reason I bought these headphones was for the ability to have them connected to my work laptop and phone at the same time. So hopefully there’s some kind of fix for it.

1 Like

Do you know what bt versions the phone and the laptop have?
I suppose these are different ones.
This could be a reason of this issue.

But of course you are absolutely right.
The earphones should work with different devices “simultaneously”.

1 Like

It was hard to find on my laptop, but I think it might be version 5.2 and I have a pixel 5 which I believe is version 5.0, not totally different versions, but maybe different enough that it makes them incompatible?

1 Like

Could be, I really don’t know.
I am out of the game now.

Did you contact the support?

I think we have already checked out all error sources we know .
We few here (not the support :smiley:) couldn’t help you.

We are only forumners with a little bit of knowledge.

1 Like

Hehehe, all good! I appreciate the help for sure. And yes, I contacted support this morning through email, so hopefully they can come up with a solution for it. I’ll keep you updated.


Do that please.
If they got better ideas we would like to know these of course.
Good luck! :smile:

Thanks for the update. Hopefully support will be able to sort you out.

No I don’t believe there is a fix that. It’s a limitation of the hardware they used.

You may get lucky if you have nearer to each other hardware/software between two devices.

It’s not just BT versions, there’s profile versions and Windows tends to “hog” the connection even when it’s quiet.

At least you know the workaround for now.

To swap between devices you turn off the bluetooth of what you’re leaving, turn the headphones off, turn on the bluetooth of what you want to use next, turn headphones on. You’ll find you can swap one direction better than other direction, usually from older to newer.

In Soundcore’s defence, the products are reasonably priced so you can dedicate to a task, so don’t need multipoint.

In criticism of Soundcore they state multipoint but it is very finnicky, works well in very specific narrow situations. e.g. they work well for me as I switch between Android phone and Android tablet.

So one could test if it works with two WIN devices.
Would be interesting.
I am sure there is someone here who can do that test.

I dont have such a Q35, if so I could test it with LINUX devices. :laughing:
Don’t you own 2 LINUX laptops @The_Professor ?