No connect to the soundcore app

Liberty 2 pro
I can’t connect to the soundcore app

bluetooth connection works!

When you try to connect to the soundcore app do you have both buds out of the case?

1 Like

@Christoph As they connect on BT it seems the issue is more to do with the app rather than the buds, have you tried a re-install of the app?

You should delete the app and install it again.
Are are sure you got the latest version installed?

Thanks for your advice, but unfortunately neither reinstalling the app or anything else helps. Incidentally, I have an iPhone XR.

May be you have the possibility to use another phone with Android and try it with this device.

I just posted about having the same problem. I have an iPhone 8. My life NCs connect to the app but the LP2s do not even after resetting them, reinstalling the app (all of this several times). Like he said they connect to Bluetooth but not the app.

If he can’t pair it with HIS phone then what’s the point lol.

The point is if he can not pair it with THIS phone.
May be it can be done with another item

Well I have a different phone and the same problem so…

You are talking about Iphone as far I see.
My be that app doesn’t work special Iphone models.

So it works with my Life NC but not these. Na doesn’t seem right. Not the phone. It’s the product. Aka LP2

You should contact the support.

1 Like

I did. They are taking a while because of the holiday.

1 Like

Good luck and sorry for some misunderstandings.
English is not my mother tongue :wink:

1 Like

No worries. I’ll be posting an update once they get back to me.

1 Like

Support got back to me and gave me a series of steps to try and reset them…didn’t work. I mean they reset but still don’t connect to the app. They also said if that was the case that I should take a pic of the serial number and send it to them and they will give me a replacement. I love Anker. People can talk shit all they want about Apple and their “superior” tech, but all that means is they have never tried an Anker/Soundcore product (I’m mostly knocking the AirPods, waste, of, money) but I guarantee their customer service doesn’t even come close to Anker’s (and you prolly have to pay for it!)

Setting up an exchange…oh well I just go back to my Life NCs in the meantime. I can’t get mad at #Anker because they are so damn helpful lol.

I’ve had the same problem repeatedly. I need the app and like the app–easy to change settings but often AFTER the app is properly connected it drops (the app won’t connect to the bluetooth). Mighty strange. I’ve uninstalled and reupdated.

The buds work though and connect to BT but not with the abilities i need.