Q30 causes bluescreens on Windows 10 when using Microsoft Teams (randomly) - cause is Bluetooth 4.0


I’ve thought that I will leave a small info with my findings. I’ve decided to register, because my headphones are failing (whistling sound when ANC is on), BUT before I’ll try to exchange them I wanted to leave this message to the community, because it took me litterly months to narrow the cause down :).

I’ve been using the Q30 since March 2022, and I like them very much. However immediatelly one issue start to happen randomly during Microsoft Teams converstions - a Windows bluescreen occured. It could show up in like few first minutes of a converstion, or a 3 hour long meeting could’ve work just fine. It could happen once per week or two, or two times a day. Seriously not much of a common denominator here, and I myself work at helpdesk, so generally I do know how to narrow stuff down.
The issue was not that pressing for me, because I have many headphones to work from home.

I do not have the bluescreens screenshots now, as I’ve solved the issue like 6 months ago.
All drivers (for Windows, BT, headphones etc.) were up to date.
Issue was happening on a Dell Vostro 3578, Windows 10 Pro, i7-8550U, 16GB RAM.
That’s a laptop from 2018 (works fine with a SSD for office work)
The key spec here however is the BT/Wifi module (I keep wifi turned off on work via ethernet)
Qualcomm QCA9565 Bluetooth 4.0

I’ve tried various drivers for that module, with no difference.
However when analyzing the Windows event log it seemd that (almost) always the bluescree comes after “a device” is trying to get into a low energy mode. Not all such entries resulted in a bluescreen, but this was the only common issue. Which is weird because BT 4.0 should work fine.

Anyway, after disabling the inbuilt wifi/BT module in the device manager, and buying an external USB BT adapter (Asus BT-500 in my case, which is a 5.0 device) everything works fine.

I wonder what the issue here is, because I doubt it is the BT 4.0 itself. Compability with MS Teams? Perhaps headphones are marked (wronglyu) as not being used during a Teams call, and there is a conflict when they are to go into a low energy mode. Who knows. I do know what has solved my issue, and I do wish to remain with the Soundcore brand, after getting my Q30 replacements (and am waiting for a better price of Q45 to check them out).

Have a nice day and if Google will direct someone here searching “random Windows bluescreens during Microsoft Teams calls / meetings when using Soundcore Q30 headphones” I do hope this solution will help them.

1 Like

You wrote a lot.
But as far I can see the issue is on WINDOOFS side.
I dont like this this OS so I can not give you more advices.
(May be it should be possible to take a deeper look inside the bt protocols)

BT versions are usually compatible downwards e.g. 4.0 is compatible with 5,X

As far I see you have really updated the bt driver of you bt card to the manufacturer’s driver.

May be you can write an email to the support, hope you get an satisfying answer there.
But don’t expect too much.

I’ve provided a solution that worked.
I am well aware of the downwards compability od the BT protocol, as well as the fact that BLE was introduced in 4.0. I’ve searched answers in many places, starting from Microsoft, and tested various different approaches like e.g. changing the energy states of various devices, changing the HID settings, changing the power supplyu etc. and all that crap.
It was happening only during the Microsoft Teams calls, and I am also aware that various headphones have issues with that app (like e.g. Huawei Freebuds 4i which crackle randomly during the calls, and Huawei does not care (also only on Windows, on Android it is OK). That’s why there is a “certyfying” process for headphones and MS Teams.
While I might not be fluent in English, or have much time to spare, I’ve been solving hardware, and software related issues for years, so do not expect for me to provide a long list of everything what was tried.

I could be listening for hours of media content (Spotify, web browser streaming, Foobar, VLC etc.) with absolutly no issues on this system, so I do not thing it is a Windows issue, more like a MS Teams or Soundcore issue

But as I wrote - I’ve found my solution and am leaving this messeage for people with a simmilar problem, as well as for Soundcore itself, as they might inculde checking this configuration in thei future quality checking process, and determine if the issue is in the area under their control.
You’ve made a strong statemnt (a Windows issue) without any research, or proof. Perhaps your are right. If not, then Soundocre should care to provide flawless experience if their tools are to be considered seriouslyu for home office applications.

Take care.

1 Like

OK, fine,
I am not in Windoofs anymore (you know “DOOF” means stupid in German :rofl:)
I was fighting with LINUX problems for many years when I did my job.
Still doing this sometimes, BUT if there are any issues which could be solved,
there is the LINUX community.
And there are fantastic helpers (developers etc. )

Being retired now, there is no more need to use this “doofe” MS.

You are right. Personally I do hate Microsoft Teams deeply, and wish my company has not moved from Slack, but what you gonna do. It is too bad that Linux does not have a strong position in the typical office work, as it has in e.g. server applications.
But that’s a reality we live in.