Q30: feedback in NC

I get random feedback when using my Q30 headphones in NC mode.

First happened when I was streaming a show on Netflix. I was using my Roku with the sound streaming through my Android (pie) phone. All was good for about 30 minutes then I got this high pitch squeal. I turned off noise cancellation and it was all good. This was in the bedroom.

The second was watching Netflix through my Android 11 tablet. About 15 minutes this time. Same results. Happened while I was at a doctor’s office.

And today while listening to Spotify on my Ubuntu 21.4 pc. Over an hour this time. In my home office.

Always through bluetooth.

Has anyone had similar issues? Found any fixes?



Have you tried a reset of the headphones?

I had that on my son’s q30s. You will need to reset the headset, lose connection to all devices, reconnect to the devices.

Since the headset was my son, I can not tell you about any squeal. They ended up replacing them for him. They will ask you to at least do all the above first.

If it is still there contact service@soundcore.com for additional assistance

Happened to me on my 2nd set, squeel on left side, I opened a ticket and got a replacement without that fault. I bought through Amazon in UK and I know replacements can be more problematic in some parts of the world so YMMV.

I can cause a squeel using ANC on my Sony headphones if I block the microphones, but with the Q30 it was constant and regardless of covering.

I would try resetting and forgetting connections as per the above recommendation.

If that doesn’t work, contact Customer Support.

Thanks for the suggestions.

I tried resetting and then on Saturday during a live Zoom event that I was part of, the feedback happened again!

I’ll contact customer support.