Right earbud will not work at all and resetting doesn’t work

I’ve had the Liberty Air 2 for almost half a year and there’s never been a major issue, but then, all of the sudden yesterday my right earbud will not work. At this point it won’t recognize my right bud at all, it
Only see my left one. In fact, it has FULLY confused my right earbud for my left bud, so that whenever I connect my right one, everything plays through and is controlled by my left bud. It like it believes my left is my right.

My right earbud still active and connected somehow in this weird way—if it tap it play or pause my phone, or if I hold it it will pull up Siri on my phone, so I know it isn’t dead, it just won’t properly connect. I’ve followed all of the suggestions including the hard reset option, where disconnect them from your phones Bluetooth, turn off Bluetooth, put the ears buds in the case, leave it open, hold the power button for 10 seconds, and reconnect. I’ve tried these suggestions many times and still nothing,

You’ve tried 99% of what we’d always suggest so its probably a dud earbud but there is a couple of slightly different things you could try (and good luck).

Wipe clean the metal contacts on both buds and use cotton tips to clean contacts in the case, using isopropyl alcohol. You need to own this for regular cleaning of most electronics you touch, particularly ones used in ear.

Note the reset signal needs a good connection between buds and case, hence why the cleaning. The reseting with the case opens reduces pressure on the connections in the case so any kind of contact issues can persist and be why the reset may not be working.

Plug case overnight with buds in, pressed firmly in , case closed to be sure fully charged.

Then.

Go far away from everything (in a field, etc) so no bluetooth interference from anything, take a Powercore with you so its the buds, phone, Powercore, USB cable.

Note this is because rarely a bad electronic device locally can be blocking bluetooth particularly if one bud has a slightly bad antenna weld.

Delete phone pairing. Turn phone bluetooth off. Turn phone off.

Plug power into case (you had not done this while powered before), open lid. Press hold reset 10+ til both buds flash red. Some reports is that the reset works more reliably while case is powered. If doesn’t look like worked, then press the buds in firmly, if doesn’t work, try wiggling them a bit.

Wait a minute.

Turn phone on, enable bluetooth.

Take right bud out of case, and pair R bud. It will offer to pair L so immediately accept.

Then see if it’s fixed.