[SOLVED] Issue with Soundcore app not detecting my Liberty Air 2

Good Evening,

I’m a proud owner of a Soundcore Life Q20, since i love the product so much i decided that my Earbuds would be Soundcore also, i just got my Liberty Air 2 this week and in the beginning all worked well, paired and installed the app, i remember it saying that they were on the latest Firmware.
Then the issues started, 1st the app stopped being able to connect to the LA2 and then it got worse, when i closed the lid with the them inside after 1 minute my Smartphone managed to connect to them again and kept playing the music or whatever even with them inside and they were actually reproducing the sound or call.
Went to find how to reset and unpaired and did the reset and paired again, it solved the issued of them, working when they were supposed to be off, but the app still doesn’t connect to the LA2.

What i’ve tried so far:

  1. Unpair, reset the LA2, pair the LA2 and tried the app, still doesn’t find them.
  2. Removing the app, Unpair, reset the LA2, pair the LA2, installing the app and tried the app, still doesn’t find them.
  3. Removing app cache and data, Unpair, reset the LA2, pair the LA2, installing the app and tried the app, still doesn’t find them.
  4. Tried installing the update firmware app for Windows 10, but i guess wasent made for the LA2 since it doesn’t even detect them.

They are paired correctly, i’ve had the app working on my smartphone before, android by the way, they show up as Soundcore Liberty Air 2 and Soundcore Liberty Air 2-L.

Any ideas? What can i do to solve the issue? they work fine sound wise but cant change profiles, update, etc.

Regards.

Ok, went on crazy mode and tried anything that i could try and solved my problem and after searching more into the community others have the same issue.

What i did:

  1. Cleared the Data and Cache of the Soundcore app
  2. Uninstalled the Soundcore app
  3. Unpaired the Soundcore Liberty Air 2-L and then Soundcore Liberty Air 2
  4. Made the Reset by opening the lid with them inside and holding the button for 10sec.
  5. Paired the Soundcore Liberty Air 2 and then when prompted Soundcore Liberty Air 2-L
  6. Only now installed the app, logged in, added the Liberty Air 2 and worked like a charm

The main difference was installing the app after everything else was ready.
By the way my firmware is 01.57, is it the latest one?

I do not have those buuuuuuuuuuutttttttttt there are 3 versions of them. One with auto pause, and with a combination of single or double tap… 4.xx, 10.xx and 1.xx

Unsure latest on yours. Since connected, you should be able to check for updates…

Mine has the double tap, the firmware says 0.157, checked the box and i believe not much information is there, had no clue that there were so many versions, they just arrived this week so i guess the latest ones?

Lol. We didn’t either but after a few threads, we figured it out. For some reason I thought your version had double or single tap ability. I had a post on a thread that I thought I wrote it out. Anyways, they are good buds… enjoy

Well i can single tap to up and down the volume, and double tap to forward and back the music, i can also hold for assistant, is that what you were asking?

Yeah… so your firmware will be the 1.xx.