Soundcore Liberty Air 2 pro on MacBook Pro Monterey problem

Just bought the Soundcore Liberty Air 2 Pro. Every few minutes the sound cuts out for about half a second. Did ALL of the above and more:
Reset BT module
SMC and PRAM reset
no other BT devices connected
no other BT activated devices near
deleted the Bluetooth files
reset the liberty air 2 pro
fiddled with the com.apple.BluetoothAudioAgent settings
reset everything again. Problem remains.

tried my 20€ Xiaomi Airdots… they work fine.

Any more ideas?

You appear to have been very thorough, I don’t have a Macbook nor these buds but the only thing you’ve not mentioned is that must wait at least a minute after resetting the buds before you pair them.

I also see you already aware to not have anything else paired nearby but what may be happening is the reset is not being done correctly (wait at least a minute) so there is a prior paired something connecting and causing a fight.

So you do the reset then you wait at least a minute with the buds in the case before you attempt anything else.

If your reset is still happening I’d open a ticket with service@soundcore.com with proof of purchase and serial number and a write-up on what you’ve attempted already.

1 Like

Just out of curiosity: Have you tried pairing the Buds to anything else? I have the LA2P and they don’t behave in that manner.

1 Like

@The_Professor Hi! I did not know that, will try to wait a minute next time.

@Steve976 Hi! I also paired them with my android phone and they worked perfectly.

At the moment I’m also struggling that they won’t charge ^^ So maybe they are just broken…

If they won’t charge that may be a sign of debris between the buds and the case pins. If that is true then the reset signal from the case won’t get to the pins.

So clean with isopropyl alcohol and let dry.

They also could be broke but the above is trying to help… if they are new the debris cause is highly unlikely, it does happen more commonly after a couple of months.

Solved!

  1. The charging problem seemed to be some compatibility issue, they charge normally on a dedicated fast-charger.
  2. The sound skips are a bug of Monterey. To solve: go to system preferences -> sharing -> unselect AirPlay Receiver. Problem disappeared!
1 Like