Soundcore Liberty Air 2-They both work but not at the same time?

Hello and good day!

I’m hoping you can help me with pairing my Liberty Air 2 Earbuds.

First, i purchased them yesterday on , at my local Electronics Retail Shop

I followed the directions on the manual, and it is not working for me.

Critical Information: My Phone : Brand new Samsung Galaxy 10 plus( i wait a year and buy an older phone at a better price!)

OK…

So:

  1. The earbuds are removed from package and inserted into case;
  2. Case is left until a full charge
  3. Phone Bluetooth is turned on and scanning for device
  4. Immediately, it identifies : ( Soundcore Liberty Air 2-L) and (Soundcore Liberty Air 2)
  5. I press the first one, it connects
  6. I press the second one, it connects
  7. I put on the earbuds, turn on some music on my phone and music only emits from one earbud.
  8. Not that it won’t play music in the other earbud, it will only play from one side or the other. Not both together.
  9. Now, the manual says, tap twice to pause or play music. OK. I tap the side thats playing and it pauses the music, then i double tap the other earbud, that wasn’t playing, and it starts playing music from that side only. So it can go back and forth. I keep playing with this, the one that plays, I double tap, it pauses, as it should,i double tap again, and it resumes the music, as it should. Like i said, after the pause, i double tap the earbud that wasn’t playing and it begins playing, but leaves the other earbud muted.
  10. So, my next attempt, i turn on the music, and open the Soundcore app.
  11. First thing that appears, is a screen, that says , " Searching"
  12. Next screen says, at the top of the page, " Select"
  13. I’m given 2 options: Liberty Air 2 and Liberty Air 2
  14. Since they are both the same, i click on the top one, " Connect "
  15. This next screen, is where the app stops and won’t let me continue on any further. The page is of the two earbuds, one is prominently shown, with the letter L , wrapped around a broken/segmented green line. The other earbud is shown, but not prominently, its kind of shaded out, yet clearly visible.
  16. When i touch/click on the L with segmented green circle, it displays, what looks like a full battery symbol, for 2 seconds, then goes back to the L wrapped around a segmented green circle.
  17. At the bottom of the page, is text, that says: Connect both sides of device to explore all features"
  18. Also, the prominently shown earbud, " L ", which I’m sure is telling me , that this is the Left ear bud with full battery charge, but as I’m walking through this explanation with you, the music is coming out of my right ear.
  19. So, I thought I’d try something different. Because of point 18, I double tapped on the right ear bud, it paused, then i double tapped on the left side, and the music resumed, on the left side, but, it changed nothing about the screen image. It still only showed the left earbud prominently. I’ve attached a screen shot at this point.
  20. Done! I don’t know what to do at this point. Your help would be greatly appreciated.

Thank you.

Delete all pairings and reset the buds via putting in case and I think it’s press case button 10 seconds.

Then take out just the right bud, let it pair, it will then offer to pair the left even though it’s in the case off, then take out the left bud and it connects.

1 Like

Hey Professor, thanks, but i followed the steps, but it wouldn’t work.
I deleted all pairings, reset the buds, put in case, and held the under case button for ten seconds. During the 10 seconds all three lights stayed alit. After finishing that, the three lights turned off. Ok, Right bud is connected in my right ear, but no offer to pair the left bud which is in its case, and it is flashing. My phone recognizes it only. So i tap on its name on my phone, then i get the offer to pair the left bud, which is accepted. So now, my phone’s Bluetooth list shows both buds as connected. Now when i turn on some music, Now, i only get music from my left bud, because, i assume, it was the last one to be connected. Even though, music is only coming out of the left bud, when i double tap the right bud, it pauses the music, when i double tap the right one again, then music comes out of the right bud, only.

Weird stuff?

You shouldn’t be connecting left manually. The LA2 manual states that you should only do that when using left only so you should just take right earbud out, then left and your phone should automatically connect to “Soundcore Liberty Air 2” which means your right earbud (primary) is connected to your phone and your left earbud (secondary).

Let me if that helps

This. Follow the directions, and there should only be one pairing process to get both earbuds connected through one connection (they are already paired with each other, so once one is connected, both are in general). If you separately pair each earbud with your phone, they won’t be paired with each other, and your phone will only support one at a time, so you won’t get the desired results.

1 Like

I only pair the right but as I pair the right, without me doing anything the left is offered to be paired. So from a clean slate, if take out the right bud, I see it to be paired, if I pair with it and connect then even though I’ve yet to take out the left bud, the device is asked if I want to pair with the left bud. So pairing with the right causes a pairing with the left.

Then what is connected is a function of which bud I take out. If I take out the left bud, connect to the left, then take out right bud, only the left is connected but both buds work.

This is the same across the BT 5 and BT 4.2 devices. This is the same with LA2 and LP2.

So either user error (less likely as we exchange information) or I think more likely is these two buds have forgotten they are a pair and a full reset would be my go to reply. Full reset video. If a full reset where both buds learn about other via being reset in the case, then by elimination it must be dud and so initiate warranty process.

Thank you for all your help. The soundcore team in USA, got back to me, gave me some advice and it worked great. Thank you all for your guidance. Cheers.

The below text, was the instructions from Soundcore service.

Thank you for contacting Soundcore Customer Service. We are very sorry that you have encountered issues with your headphones.

We kindly ask you to try the following steps as those have proven to oftentimes already help:

  • Delete (forget/ignore) the pairing records for the headphones (both Liberty Air 2 & Liberty Air 2 L) on your device (phone/tablet/etc.) and turn off the Bluetooth.
  • Reset the earbuds using the following steps:
    1.Place the earbuds back into the charging case and keep the case open.2.Tap and hold the button at the back of the case for 10 seconds until both earbuds’ LED lights flash red 3 times.
  • –> After the reset you will see the white light flashes quickly on the one earbud and the light flashes slowly on the other side, which means they pair together.
  • Turn on the Bluetooth on your device again, search for the Liberty Air 2(not Liberty Air 2 L) and pair the device to see if that worked.
  • Please try with another device (phone/tablet/etc.) and see if the issue is the same.

Note: When there is a pop-up window for you to confirm pairing. Select “pair”. If you select “cancel” accidentally, you need to delete the earbuds from the device’s Bluetooth history and re-pair the earbuds.

1 Like

Cool. So what I wrote above would have worked too.

1 Like