Soundcore liberty neo connection issues

Hello i purchase neo last eek and the audio connection drop of every 2 or 3minutes .can someone help me to fix this. I really like the earphone but it’s so frustrating can’t listen the whole song with peace

I recommend that try resetting them. Which reset method depends on the model number of the buds themselves.

Model Number A3906:

  1. Turn off Bluetooth on your device.
  2. Double click the multifunction button on the left earbud (while it’s turned on) to make the white LED indicator continuously fade in and out.
  3. Double click the multifunction button on the right earbud (while it’s turned on), to make the white LED indicator continuously fade in and out.
  4. Place the earbuds close to each other, until the white LED indicator on the right earbud flashes rapidly and the left earbud flashes slowly.
  5. Switch on your mobile device’s Bluetooth, select “Soundcore Liberty Neo” from the Bluetooth list, and pair.

Model Number A3911 (with a 9-10 digit Serial Number under 31, example, SN: AC3PNS0930500506)

  1. Delete “Soundcore Liberty Neo” from your device’s Bluetooth list.
  2. Take the earbuds out of the charging case and hold the button on each earbud for 5 seconds until you see a red light. This indicates they’ve turned off.
  3. Hold the button on each earbud again until the LED indicator turns pink and then turns off. Put the earbuds back into the charging case. Make sure the charging case has power and there is a white light on both earbuds.
  4. Take both earbuds out of the charging case and place them near each other. The indicator on the left earbud will flash slowly, while the LED on the right side flashes quickly.
  5. Go to the Bluetooth pairing list on your device and select “Soundcore Liberty Neo” to pair.

Model Number A3911 (with a 9-10 digit Serial Number equal to or greater than 31, example, SN:AC3PNS0932500506)

  1. Delete “Soundcore Liberty Neo” from your device’s Bluetooth list.
  2. Take the earbuds out of the charging case and hold the button on each earbud for 5 seconds until you see a red light. This indicates they’ve turned off.
  3. Put the earbuds back into the charging case (when it has at least two white LED indicators on the case), and then hold the button on each earbud until you see a flashing red light.
  4. When the LED indicator on the earbuds turns white, take both earbuds out of the charging case and place them near each other. The LED indicator on the left earbud will flash slowly, while the LED indicator on the right side flashes quickly.
  5. Go to the Bluetooth pairing list on your device and select “Soundcore Liberty Neo” to pair.

Hey @TechMan. Do you the resets instructions written out or are you grabbing those from a manual instructions.

i reset it and it fine for first 15 minutes after that the audio dropoff return.

I am sorry to hear that. You will probably need to check with Soundcore support.

I did have a question. Did you try it on a different device? I think this will help verify if it was the product vs the device.

1 Like