Soundcore neo not working with ms teams - not working with Windows 10 laptop

I love my neos, but for some reason they do not work with ms teams. Whenever I sign in to ms teams with soundcore neo connected, I get the error that the device is not working properly and then the whole sound service on my laptop gets disconnected and bluetooth on the laptop gets disconnected.
They work fine with all other programs.

Ok, I have to say that is weird. You can always do a reset and reconnect which I would do first. I will say through other have had issues with Bluetooth drivers that they updated (or used a generic driver for it).

The last thing I can think of is from the picture below, you can try to go to bluetooth, find neo, click cog, and click mic to to use to talk n listen.

OK, I think the issue is with my laptop, windows 10. I updated the bluetooth drivers from Acer - I’ve an Acer spin 3.
The bluetooth says it is connected to the neo, but neither can I hear nor use the mic on these.
Once connected, I cannot disconnect them, nor remove them. Then I also tried to switch off bluetooth, but now I cannot switch it on again, without going into services.msc.

1 Like

OK, clearly, the laptop was not a problem. I just got a brand new laptop with windows 10, and the same problem with neo headphones.
MS Teams gives error that the speaker and mic are not working when I connect the neo headphones. Other bluetooth headphones work fine.

Seems like Teams is a culprit in alot of TWS headphones. I’ve posted a response to similar (albeit with different earbuds, earlier). Link below to my other reply within the community:

Check out the details there, and let me know if it helps at all.

Yes, I have already tried that, and that gives the error, that mic/speaker not working and choose something else. Also, with these options, I could not hear anything, and neither the other parties could hear me.
So this does not work.
I had opened the issue with MS support, and they closed the ticket without ever suggesting any solution.


I know that the Bluetooth update usually fixes it. In one of the post, a user said that he downloaded a generic Bluetooth driver to get it to work

1 Like

so do you suggest I download a generic bluetooth driver, and see if that works?

Yeah… I know updating the Bluetooth helped in some instances but do know that one person did the generic BT and stated that was what fixed it for him…

Hi All,

I also faced the same issue. I was able to resolve it and now it is working fine in Microsoft Teams. Here is what you need to do.

Go to Windows Settings -> Sound Settings (Search for Sound Settings from Windows start )

Once the screen opens, click on “Manage Sound Devices”.

In the next screen, There will be two sections for “Output Devices” and “Input Devices”

Check if any of them are in the “disabled” section. If they are disabled enable all of them

Basically, you should not have any “disabled” devices in both sections

Then try a Test Echo Call in Teams.

It works!


Thanks for this. But I checked, the neos are not disabled in the output/input devices section. They work with everything on the laptop, except MSTeams.

Maybe you should write to Microsoft Answers.

I know a few other devices where the uses had do a setting in MS TeM s to get it to work. You will have this whether it was soundcore or another brand. If it is the Liberty neo, you should also make sure it set on for call and not audio as well

already did, and they answered since it is not due to ms teams, or microsoft, they cannot help.

what settings, can you please specify?
for bluetooth, i connect the neos as connected for calls and music.

yeah bluetoorh…

I would say turn off the audio and leave calls on. You most likely will have to do something on teams audio setting as well…

I use the web version of teams on my work laptop and I have to use a work usb headset. I have had issue with teams with the usb headsets as well. I had to close it out a few times to get it to work with them.

I think you are showing on a phone or tablet?
I use my windows laptop, and in bluetooth, I cannot see any such settings for any device.


You are correct. I am not in a place to check my pc settings.

To me it seems like Bluetooth version compatibility issues. If i am not wrong, Neos have Bluetooth version 5.0 and check your bluetooth version of Acer Audio Driver…

“Bluetooth 5 is only backward compatible with Bluetooth 4.0, Bluetooth 4.1 and Bluetooth 4.2, but to get the speed and range improvements you will need to have a Bluetooth 5 device connecting to another Bluetooth 5 device. If you buy a new smartphone with Bluetooth 5, it will operate as Bluetooth 4.2 if you are connecting to a Bluetooth 4.2 device. That means that you’ll still be able to connect, but you won’t see any benefits. Bluetooth 5 won’t connect to legacy devices.”

This link should help you in finding the compatibility …

It may not be the same as “General Bluetooth Adapter”. It may be Intel or the one proprietary to your ACER

Open the one which has an Advanced tab in it.