Sounddcore Liberty Neo case not holding charge

Hi ive had a Soundcore Liberty Neo for a little over 5 months now but for somereason the case as stopped holding any type of charge for the past few days. When i put the ear buds in the case and charge it the earbuds charge but not the case. Ive tried different chargers and even left it charging over night but no matter what i do the case wont hold charge. i’d really appriciate if i could get any suggestions to fix this problem because i have no idea on what to do and i cant find any info onilne to help fix this problem.

1 Like

Try this.

Check case charging port for debris. May involve a magnifying glass, remove with non-metal object, e.g. plastic tookpick. Reason: every time you plug into power some debris off the charging cable gets pushed into the case port.

You said you tried different chargers, but not mentioned cables. Try different cable and charger - known to work. Reason: cables fail over time. Use ones you know work.

Plug case into power and keep it plugged in, leave connected to power. Reason is cases sometimes cannot reset themselves without power.

While case connected to power with a known cleaned case port and known working cable and known working charger, follow the reset instructions.

1 Like

omg bro thanks, i cleaned the case port and tried a different cable and now its charging. Thanks so much man!!

1 Like

The cable which failed may itself have debris pushed into it so clean it may make that cable work also. But cables fail for many reasons all over their length each end. Now you know it was case port / cable, then see if it was specifically the case port or the cable. Don’t necessarily discard the cable you think failed.

1 Like

Hi, @Mayrushart I am so glad to hear that your problem has been resolved. Please continue to use it.
If anything else needs our help in the future, please drop an email to "", our Soundcore technical support team will take care of your case within 24hrs.