Sport x10 buggy

Hi, many people have this problem and so do I.
The headphones are too quiet (everything is at full volume) and the videos have a delay with the sound. Depending on the smartphone and app sometimes up to 1.5-2 seconds.
But most have a second delay.
This is not technology from 2022 and ridiculous for anker standards.
can anker fix this with updates or will it always be like this?

Hello, @Muhammed_Gungor sorry to learn about the issue with your Sport X10 earphones. For the issue of headphones being too quiet, the following tips are worth trying:

  1. Try to turn up the volume on the connected devices;
  2. Reset the earbuds using the following steps:
  • Place the earbuds in the charging case and leave the case open.
  • Press and hold the button on the charging case for 10 seconds until the LED indicators on the case flash white 3 times and then flash in sequence. This confirms that the reset was successful and your earbuds can be connected normally.

Regarding the issue of sound delay, let’s see if any of the following tips are helpful:
-Use the headphones to listen to the downloaded music or video on the phone to see whether the issue still persists.
-Try deleting the pairing history on your device, resetting your device, then try to pair with the headphone again.
-Try pairing the Soundcore headphone with another Bluetooth device.

If the issue still persists, please drop an email to service@soundcore.com detailing the issue and the order information, our Soundcore technical support team will take care of your case within 24hrs.

No worry, we always stand behind your product and are ready for help.

Sometimes I really think that soundcore thinks we are all idiots.
I have written that I have turned up all the volumes. I have reset it many times and tried all sorts of apps.
Also different smartphone (Xiaomi, samsung, windows).
My question is ignored and not answered, but I am presented as an idiot. Thanks

No no, please don’t think so.
Its just an usual answer created by so called “word components”

I am sure there is a possibility to increase the volume on Android devices.
Could be in the so called “developer’s mode” of Android.
But I dont know not using Android devices.

Otherwise you should use the search function here.
I remember this “issue”
was discussed very often.

By the way I am not a member of the soundcore staff. :laughing:

I’m also sorry if I was too harsh.
But everyone gets this prefabricated answer, although the problem really many have.
But I find it ridiculous how hardcore anker ignores this problem.

unfortunately I can not find the problem with the search function. can you help me there? Thx

I usually do not have issue with the prefab answer. Although you stated you did something, they have to just verify that you may know what you are doing as a lot of folks are just not technical.

I will just add did you check to see if there was an update. If the beta group may have had issues and it was fixed then there may be an update that would need done as well.

I would check this out and you can also ask @The_Professor

I would if you do contact support to state what you done and what the admin had asked you to do as it would help make your process quicker to help figure it out or etc.

I have these buds.

I don’t suffer delay. I find volume loud enough.

Ensure the Android audio setting of absolute volume is disabled.

Where it is is Android depending, this is how mine looks under Audio settings.

I think I needed to reset buds once for some reason.

2 Likes

This article might be helpful:

Well… In case @The_Professor stated he has no delay issue and volume is loud enough seems you got defect item. I suggest to contact soundcore by email service@soundcore.com

1 Like

He did already

2 Likes

Hello all.

I have tried many things the last few days and nothing has worked. It is 100% an error from Anker.
To ignore this bug is very unprofessional.
The problem is also:
There is a lot of “fanboys” who ignore bugs because “for the price it’s not bad”.
This is stupid.
Anker for me has always been quality and good sound.
These headphones are currently worth less than 30 euro no name china headphones.

If there is no improvement in the next update, then I send the headphones back. Volume too low, delay is disaster (sometimes over 2 seconds), “bass up” function is ridiculous and ANC barely works. More noise than function.

but thanks for your help.

You should indeed open a ticket and follow their steps and return the item if agreed.

I’ve replaced 3 Soundcore Q30 and 2 Frames this last year.

Venting in public forums doesn’t work. Take it up directly via email and summarise here. It is useful to us all here to ask for a fix as then if it works a future search can find the fix, it is also useful to count how many have an issue as if it’s rare it’s probably a warranty issue, if common probably either an item to avoid or wait for updates.

Chances are you either have a uniquely bad unit and a swap will fix or a replacement proved the issue was elsewhere, as in this case you’re the only one who’s mentioned this so far.

1 Like

It totally agree that you should contact Soundcore directly.
I have exactly the same issue and contacted them. I just got the reply that they are working on that and will solve it with a firmware update very soon.
So it seems that it is a known issue on some earbuds.
That’s why I will wait a bit because besides that the x10 are really amazing!

1 Like

Headphones completely broken. nothing works anymore. Soundcore contacted. they offer no help. ridiculous. never again soundcore

I usually find they do a pretty good job on helping depending on what the issue is. The issue may come from where you bought them as sometimes the process has to go through that business than help desk from Soundcore. As long as you have a way to prove it was bought and such, I think they should be helpful. Aliexpress is one of those companies that you have to go through in order to get something fixed or returned and etc. Hope you can find help in some form. (as sometimes I have seen it is in a from of a refund depending on the country)…

I find that difficult to believe.

Assuming you didn’t make the mistake of buying from AliExpress nor lost your receipt, you’d get a replacement or refund.

Also you need to keep emails simple factual with all the information. I do that and get a reply NBD and always a resolution within 2 BD.

I’ve done I think 5 warranty replacement and 1 refund in last year, no issues whatsoever.

i bought it on amazon. I recorded sounds and videos. have proved everything. now they have written in the e-mail that they will not help me. maybe I caught a lousy employee. I’ll wait a little longer. If not, I’ll report it to Amazon.

Totally baffling.

You are emailing with service@soundcore.com ?

You should get an offer of replacement or return for refund if bought on Amazon quoting order number and serial number.

1 Like

Sorry to hear that. There may be some misunderstanding in the process. If you don’t mind, could you please provide me with a reference ticket number so that I can further check the situation and help you?

2 Likes

Did you update the firmware to the latest version?