Terrible Sound Quality with Mac

Hi, I have been using my Liberty Air 2 headphones pretty consistently since I got them in March or April. They seem fine with my iPhone, but when using them with my Macbook (MacBook Air 2017, 10.15.7), it sounds like listening to the FM radio over the phone. It is terrible. The reason I bought these in the first place was because of distance learning. I’m teaching over zoom and being plugged in is really inconvenient. It’s not just zoom that sounds like I’m listening through a tin can either, it is itunes, spotify, youtube, any sound. I tested a few equalizers and found one that I like on the app, and that improved the sound on my iPhone, but not the Macbook. Is there anything I can do to improve the sound on the computer?

What is the output set to when you listening to music on Macbook? This is a windows screenshot but should similar on Macbook as well. If you are teaching on zoom, it will switch to Headset (Hands-Free AG thing) which does sound pretty horrible. And it does this because you have mic turned on. Even if you switch to Macbook mic, it still does switch for whatever reason. I use Bluejeans and MS Teams for my lecture and haven’t figured out why it switches my Spirit Dot 2. Haven’t had that issue with some other headphone and speaker though

image

Thank you for the reply. I don’t have many options on zoom, see below. The Liberty Airs are the only wireless headphones I’ve tried. Everything sounds fine when I use any of my other plugged in headphones. I try to avoid using the built in mic since my wife teaches from home in the next room and gets picked up by the stock mic. Headphones cut down on the unwanted noise dramatically, but these liberty airs have such poor sound and leave my ears ringing after a short while. I got a set for my wife too, but she won’t even use them.

48%20PM

Try looking for output on macbook instead. Using the volume icon I think. Zoom and other videocalling apps have different output settings. If you can see Stereo option on Macbook, try using that for Youtube to see if the sound is still that bad

For whatever reason, your mac isn’t using them in the high quality music mode. There are two different modes - one to be used as a headset (mic and speakers) with lower quality. And one to be used for higher quality music listening. On windows as @Shivam_Shah showed there are usually two options to choose from.

I don’t have a modern mac to test it against, but I’m sure the option is there somewhere.

This isn’t a specific problem to Anker / Soundcore, by the way - it is an issue with the bluetooth spec. I think it was a massive mistake to not include the mic in the high quality codec profile, and hope they fix it. But as of the latest Bluetooth 5.0 spec, it will continue to be an issue for every pair of bluetooth headphones.

@Stecher_Studios, I think from @jercox comment has stated that if all else fails, you may need a Bluetooth update if all else fails.

Thank you all for your input. I found more audio settings in the utilities. There are other options but for some reason I cannot select them. I’m not even sure what these settings mean TBH. I’m going to try updating to OS 11.0.1 hopefully that will help.
55%20PM

Moving from a recent version of Mac OS X to 11 shouldn’t make much difference; you can try it if you want to upgrade anyway though. Your Mac has full support for modern Bluetooth already.

Unpairing the device and repairing might help.

Zoom will always be an issue, because it uses the mic and will thus always use the lower quality sound codec. But for music playback it should use the higher quality sound system automatically.

If you are near one, you might stop by an apple store. They should be able to support you in properly connecting your Mac to any Bluetooth device.

Well, I updated to Big Sur and updated the firmware on my headphones. I also did the custom hearing test thing. I definitely have better sound now, but as soon as I open Zoom, it all goes to shit. Which is unfortunate, because using zoom is why I wanted wireless headphones in the first place. Not that I am going to spend the money on them, but would Earpods Pro have the same issue?

With Covid and the influx of working from home, there are a lot of people coming to the community for help with similar issue. A lot with zoom and other services with different soundcore audio devices. If you do find out what the issue is with zoom, please let us know as well. It may just be a tweak of the setting from say audio to mic (if you have those options).

If you are noticing it in a big way with these, the odds are that you will notice with other devices. Still a little weird to me that they work better with your phone - they should be using the same profiles and sound quality either way.

It is possible that Apple’s products will integrate with your computer better than these. They have a loose relationship with standards in general, and I remember that there was something not quite bluetooth standard they were doing with airpods at one point, but I don’t know if that is still true.