Tips For Upgrading Liberty 2 Pro, Liberty Air 2, or Liberty 2’s Firmware on Android Phones

If you use an Android phone and the firmware upgrade failed, here are some tips to help you solve the problem.

What is the problem?
Some users have been unable to upgrade the firmware when using the Soundcore App on Android devices.

Why?
Both the left and right headphones show they’re connected to the device, but a pop-up on your device says you need to connect the earphones to your device. Do you remember seeing this popup when connecting via Bluetooth?

If you did not select “OK” from this pop-up on the Bluetooth menu, the two earbuds are not fully paired and you cannot switch between the master and slave earbuds.

What Should I Do?

  1. Go to your device’s Bluetooth settings and select “Unpair”.

  2. Go to the list of available devices and reconnect your earphones.

  3. When this pop-up appears, press “OK”.

  4. Now you can go to the “Update Firmware” section of the app to start the process.

If you have any questions, feel free to leave a comment below!

9 Likes

Those tips will help a lot and reduce questions.
That’s fine.

HAPPY NEW YEAR 2020

2 Likes

Im glad yall finally posted this. I always try to explain to people what they are doing wrong a d half the time people are too stubborn or stuck in their own head to understand or get what your telling them. Especially about the pop up to pair the left earbud

3 Likes

nice article, mostly for Android phones,

1 Like

This is also an issue on iOS…

1 Like

Good to have instructions. It isn’t very clear in general which products might have or need firmware updates, and that should be consolidated to a common area (rather than separated by country) unless those countries actually have different firmware versions?

Glad to see the instructions and hope to see for iOS as well.

1 Like

Good instructions to help us out

1 Like

Good info as always

2 Likes

Thank You. This helped me. The User Manual is not really that helpful.

1 Like

Nice tips. Thanks for sharing. These will come in handy!

My Liberty Pro 2s still won’t update, after unpairing and re-pairing multiple times.

1 Like

This (still) isn’t working for me. I’d had the -L one paired already, but removed and re-paired them (not the first time I’ve done it to troubleshoot). Update still gets no further than 73% before erroring out.

FWIW, tried it with an iPhone over the holidays since that’s what my family has. Same result. Left earbud remains at 1.09, right at 1.22.

@Joey45 @wipeout are you both following the pairing instructions to the T? Or are you pairing the left earbud separately after you pair the right? Because if its the later you will continuously have problems until you pair them to your phone properly

Exactly as shown in the screenshots. I just did it again (removed, re-paired, attempted to update) and it still fails.

1 Like

beethoven

2 Likes

:point_up::point_up::point_up: :+1::ok_hand::ok_hand: awesome photo edit!

1 Like

Another art from @Chiquinho :+1:

1 Like