Volume control not working on Mac with Anker Soundcore Life Q20

When I’m using my Anker Soundcore life q20 headset the volume control in my mac does not make any change in the volume level of the headphones. I have to use the buttons in the headset instead to increase/decrease the volume.

Another interesting information is that when I’m in a call the volume control works well (google meet, slack, ms teams, etc.). Also, volume control from apps like Spotify does change the volume of the headphones, unlike mac volume control.

I paired many times and the problem persists.

Any ideas on what is happening?
Thanks.

1 Like

I do not have those but what headphone options are on… meaning go to Bluetooth and hit cog… call is for teams n calls … turn to audio for music… I would try to have one on at a time to see if that helps.

I know a lot during the year has to update their Bluetooth drivers. Although it is not the issue but is another option to think about

I’m positive the issue is related to audio setting on mac. I’m a windows user so keep in mind when you see the screenshots. You should check what audio output is when you click the volume icon:

image

When you click the volume icon, you should see (I hope it is the case in MacOS as well) the audio outputs you have selected.

image

Normally when watching videos or listening to music, you listen through the stereo mode but video calls run on Hands-Free AG mode (which enables the mic). If you have that Hands-Free AG selected, you are reducing volume on that mode but your headphones would be running on stereo mode for best audio quality so it won’t adjust volume properly. Give this a try and let us know if this was the issue

1 Like

I’m having this exact same problem I think. The Windows options are not the same as Mac. I have two other bluetooth headphones and have also used my wife’s Bose QC and they all work properly with the volume, meaning when I adjust computer volume anywhere from mute to medium to full blast that’s exactly what I get in the headphones. In the Soundcore Q20s the volume has to be at full blast, and if I try to turn them down using computer volume they just go straight to mute, nothing in between. Only the Q20s do this. I just purchased these and discovered this in my first day of use. Any ideas?

Update: I just noticed when I’m using my full keyboard volume controls, a tap to turn down the volume one notch turns the volume off completely. But if I use the volume slider on my MacBook Pro I still don’t get any gradual change in volume but the volume does stay on at full blast until I turn it all the way down.

Update 2: When using the aux cord everything works as expected. I’ve restarted the MacBook, reset PRAM, unpaired and repaired. Something seems wonky about the Bluetooth in the Q20s. Rethinking my purchase :frowning:

None of the previous recommendations worked for me.

I updated my mac to Big Sur and the problem disappeared. It is a relief. No idea what was happening with Catalina.

Thanks anyway.

Lengthy post but ends well…

I’ve just updated to the latest version of Big Sur (version 11.2.3) and it did fix the issue temporarily but then I experienced the same issue again later.

Not entirely sure what caused the issue to rear it’s ugly head again but I did notice that when I connected the headphones to my Macbook air, if I heard the jingle (the sound Anker headphones make when pairing to a device) twice, followed by another jingle that sounds like an error then I know I have the issue again.

How I fixed the issue was by removing the headphone from the bluetooth settings in system preferences and then connecting the headphones again. When the headphones paired with my mac I only heard the pairing jingle once and no error jingle (that’s a good thing). Now I can control the volume from both my mac controls and my headphone controls.

I hope this helps someone because it was really starting to p*ss me off :smiley:

Step 1. Update to the latest version of OS
Step 2. Follow the steps in my last paragraph

10
26

1 Like

Thanks for putting the effort in to screenshot and detail.

You know you basically said delete pairing and pair again? That’s one of first tips we say to anyone on anything.

1 Like

My efforts were in vain as I’m having the issue again.

Are you pairing to two things after resetting everything? That’s often the issue.

If you begin with a clean slate, no pairings, all Bluetooth off, eadphones reset, Bluetooth on with just one device, pair headphones with that one device. Full stop. The end.

Where issues arise if when any Bluetooth device was ever paired with multiple devices, even of.you consciously only connect to one, sometimes you get unintended secondary connection and then becomes unreliable.

I think the Soundcore app maybe unintendedly causing the issue as folks are pairing with phone to get control and update, then pairing with something else, and most Soundcore products are not intended to work like that.

To be safe, pair with phone, use the app, forget on phone so it can’t accidentally connect, pair with another device, use with other device. If you must swap between devices, you’re going to have issues and must be attentive to power off / on everything to clear connections.

1 Like

I am also having this issue. I just found that if in sound setting I set the input device to be the q20, then I can control the volume. This makes some sense to me as it makes the double chime when connecting, sort of as if the output and input are connecting separately, if that makes sense. The downside of course is that in this mode the sound is garbage since it uses the other codec for talking and listening…

@The_Professor, there is no pairing with the app for this device; it is not supported, thats only the q30.

I had this problem 3 months ago with Catalina and then, one day for no reason, the phone started working as expected.

Now I am using another machine with Big Sur and the problem has reappeared.

Hoping that the problem will disappear on its own.

None of the previous recommendations worked for me.

I updated my mac to Big Sur and the problem disappeared . It is a relief. No idea what was happening with Catalina.

Thanks anyway.

After a few weeks using Big Sur, and after migrating to a new mac, the problem reappeared. I decided to buy a new headphones with a different brand. It is a complete disappointment for me.