Volume control not working on Mac with Anker Soundcore Life Q20

For anyone who might be purchasing a new mac or update to the latest OS Monterey, this might be useful…

I posted in this thread back in April when I was having issues using my Soundcore Life Q20 with my early 2015 Macbook air. I constantly had to connect then disconnect my headphones from my laptop to get the headphones to work.

I’ve since bought the new Macbook pro max 14 inches which has the latest macOS Monterey installed and I no longer have any of the issues I had before.

Maybe with the latest operating system update to Monterey this could fix the issues people in this thread have been experiencing.

I hope this helps :pray:


Nice to see a positive update for Mac users and the q20s. Big sur and Catalina seemed to have intermittent issues.

Now only if windoze could make similar updates…

1 Like

Update: I plugged in a wired USB Apple keyboard and the volume control on that keyboard worked as it should.

At home I have a wireless keyboard and trackpad connected by Bluetooth and neither volume control on Bluetooth keyboard nor on MacBook keyboard work.

At the office I have a Magic Mouse connected by Bluetooth and then plug in a USB keyboard. That plugged in keyboard worked for volume control.

Sorry to say I was so excited I forgot to try the MacBook keyboard with the office set up.

Thought I’d share. There must be something to decipher in that.

UPDATE: Well, wow, now my home Bluetooth keyboard is working. I paired my headphones and it was NOT working. I stepped away for a bit, came back and thought my headphones had turned off so I restarted them and the bluetooth auto-connected. It was a super crappy connection filled with static but suddenly the volume was working correctly. I then re-paired them to get a better connection and the volume is still working. And all this is happening a week after I updated to Big Sur. Maybe I should have re-paired as soon as I updated to Big Sur.

An update of the OS could create problems.
I remember after updating the bt tools of LINUX I had to “reconnect” all my speakers.
But of course all is fine now,
btw I use very old hardware. (Thinkpad T410s)

1 Like

Bluetooth was never designed for what it is being for now. It was a 1:1 design not the many:many it is being used for now.

This is particularly happening often with Soundcore as they have so many products releasing so quickly that exact combinations are rarer and often not tested.

Yes a common fix is just reset and begin from scratch.

1 Like

True! More than true.

No skilled testers needed, only such unpackers and producers of videos.

I had to warranty my first Q20 headset due to a weird hinge break that happened about a year ago, but I was able to fix the hinge “well enough” with large amounts of glue to where I had the replacement sitting as a backup for an eventual full break. The full break happened today so I opened up the replacement and was hopeful that this audio issue was just something wrong with the original. Turns out I was wrong. I have developed a workaround to get the headphones working, it’s just extremely annoying. Maybe it’ll help some of you. For reference, I use the headphones with my MacBook Pro (2015) and iPhone (11 Pro Max). Strangely, I NEVER have issues at all with my iPhone. It’s only my MacBook. Which has been updated to the latest OS’s constantly.

Here are my steps (during the process I have a video or music playing to test the audio):

  1. Turn on the headphones and pair them with my MacBook. The volume will “stick” and not be able to be raised/lowered from the Mac. Only from the headset using the buttons.
  2. Turn off the headphones.
  3. Turn on the headphones (they will either re-connect on their own or you need to repair). Audio will be crackly and horrible.
  4. Un-pair (do not power them off) the headphones.
  5. Re-Pair the headphones. Most of the time, this does the trick and the headset functions as it should with volume being adjustable from the keyboard. (Sometimes this doesn’t work though, and it just becomes a mess of turn off/ons and un/re-pairings until it does.)

I have also noticed that these headphones function very strangely with streaming videos on YouTube and Twitch. During the process above, playback will stop entirely on either service. Im probably wrong but the troubles may be stemming from something to do with how the headset can “control” playback? Just something I’ve noticed.

It really is too bad that these have this issue as I LOVE the audio quality and fit on them. I plan to upgrade to the Q35’s at some point and hope the issue has been fixed with those.

I’m the original author and this has been my work-around since then, it always works and it looks simpler than others in this thread.

1: turn on headphones and wait for connection
2: play anything for one second, you will heard a broken sound
3: manually disconnect and immediately re-connect.

And that’s all.