Anker Soundcore Flare 2 can not connect to an app Soundcore on Android 12

Hello there

Today I received my Anker Soundcore Flare 2 from official store on Aliexpress. It is working fine, has nice sound.

The problem is that I can not add it in the Soundcore app. When I open that app and tap “Add new device” it is searching and after a few seconds show the screen “Don’t see your devices?”. On this screen there are some options like “Retry” and “Set up manually”. If i choose second one there are list of devices by categories but none of them has Flare 2 (and Flare 1 also).

I have tried to reset the speaker, reconnect it to the phone, tried Soundcore app on my tabled just o be sure that the problem is not in the phone - but the result is the same. The app donsn’t see this speaker.

Why I need an app? I want to control the lights on the speaker. It is nice and cool and I want to control the colors and brightness to use that speaker as night light.

I have managed to localize the problem. Seems that it is Android 12. I took an old MI A2 Lite phone with Android 10 and Soundcore app has succcessfully connected Flare 2 with all features. I even upgraded the firmware of the speaker. But updade still didn’t helped with connection to my Samsung M33 with Android 12.

Can anyone help with this?

1 Like

Have you checked that your app is up to date.

I have an Samsung s22 plus. It has Android 12and I see it in my listing.

There may have been something in one of threads about changing a setting.

If you can not find, may be another option for help

Yes. I have the latest version of Soundcore from Play Market - 3.1.3. On both Samsung devices (phone and tabled) the problem reproduces.

There is Flare 2 in the “Help” section of the app but not in “Add manually” section.

1 Like

Oh, I didn’t mention that the problem is only with Flare 2. I also have Soundcore Life Q30 and its working great with both devices and Soundcore app.

1 Like

You can always try to reinstall the app to see if that may help.

Already did. It is simply not working not on Samsung M33 not on Samsung Galaxy Tab S6 Lite.

1 Like