L3P mic don't work for voice messages

Hi I’m using liberty 3 pro with Xiaomi 12
And while sending WhatsApp audio messages when phone is connected to Bluetooth earphones it is using always phone’ mic only.

but it working on WhatsApp calls and normal calls also.

if somebody know the solution pls help.

1 Like

Check your pairing has “voice calls” enabled, and not just media.

Sometimes a pairing gets confused, so delete pairing, reboot phone, reset buds, pair. Often simply things like that fixes most issues.

Everything is enabled, I tried everything, also I checked with other headphones and phones and it seems Whatsapp always use mice phone for voice messages

Look in Whatsapp settings?

Xiaomi Android user here. Same issues with with Space A40! I didn’t have this issue with Soundore P3i on the same exact phone :confused:

Whenever I record voice messages, the apps use the built-in microphone instead of the earbuds mic. The earbuds mic only works when making/receiving phone calls.

I’ve also tried resetting buds, deleted pairing, reconnected, checked in the Bluetooth options, and whatsapp options. No luck.

Has anyone found a solution yet? After reading around, it seems to be quite common with other Soundcore earbuds.