Liberty 3 Pro - Not showing up on Bluethooth lists

I got a new phone (Pixel 6a) and tried to use my Liberty 3 Pros with it. At first they connected to the phone, but would not connect to my PC as well as they had before. I had both devices forget the Liberty 3 Pros and tried adding them again, but the app could not detect them. I reset the Liberty 3 Pros and tried again, but they were still not detected. I uninstalled and re-installed the app, then tried again, and again after resetting the Liberty 3 pros again. No luck. I tried paring them outside the app, but they don’t show up on my phone’s list of available Bluetooth devices OR my PC’s list now.

What’s my next move?

Hey Russell
i am having the exact same issue
very annoying


Go in to the phone settings and rest the network and Bluetooth settings

That is quite a drastic action, I’d not recommend it.

What we have here is a classic “oldest version first” bug where the buds are being asked to connect to a modern technology (Android) and an old technology (PC) where the buds will only work reliably if connected to the oldest first, so appears as a “random” problem where if you happen to connect to PC then phone it works but if phone then PC doesn’t work.

The key is to not ever share between devices, if you must then do it between similar versions, e.g. between two Android devices. If you can’t accept that some perverse reason then turn the bluetooth off of a paired device you don’t want to use, then buds in case, wait 10s, buds out of case and connect to the paired device you want to use.

Sometimes Android gets confused itself, the fix is to not reset network settings (overkill), but delete pairing which is confused, disable bluetooth, to boot to recovery, wipe cache (not data), boot, enable bluetooth, pair.

Tried turning bluetooth of all my devices and still the liberty 3 pro does not come up on the bluetooth list on my iphone. tried to connect manually with the app too. No joy.Very frustrating

Did you do all the intervening steps you didn’t mention? So all bluetooth off, buds in case, wait, bluetooth on phone, buds out of case?

Also some pairings so awry so the full steps is:

  • delete all pairings on everything ever paired, phone, PC, everything. This helps to stop them connecting later.
  • connect buds case to power - this helps with this reset
  • while case connected to buds, reset them, they’ll need a minute to fully complete reset so go straight to next step
  • reboot phone to recovery, wipe cache (not data), this will fully eradicate a bad pairing, boot
  • by now the buds have finished reseting, enable phone bluetooth, so see if you can pair on phone.
  • If not then the best guess is you haven’t disabled the bluetooth on the PC which is stealing the connection so double-check and go back to the top step again.

BTW if you’ve got a Samsung you need to toggle A2DP hardware offload - you didn’t say what phone you had but Samsungs are flaky with non-Samsung bluetooth devices.

Before I saw that The_Professor had a chance to weigh in, I spotted a suggestion in a Reddit thread on a similar problem that suggested, after forgetting all the connections and turning off bluetooth on the target and prior-paired devices, to let the buds drain overnight. Sure enough, the next morning, I put them back in the case, let them charge for a few minutes, and they appeared on the bluetooth list of my phone, paired via the app, and then with my Windows PC.

1 Like

Useful - that draining should not be required if the case and buds are properly working, if the case is not sending properly the reset signal and/or the buds don’t turn off when put in case and lid closed, then the buds turning off/on doesn’t not occur and so they’re locked in a confused state.

That means, if the draining is required, there’s a hardware fault so should be swapped under warranty asap.

Hi. I’ve had more than a few earbuds to know to test them before their warranty runs out.
I had the Liberty 3 Pro for about a month before they stopped producing sound. I could see they were connected to my Note 9 and to my Sony X91J, but no sound. I tried disconnecting and forgetting the earbuds to reconnect again. And I was able to reconnect but again with no sound. Very disappointing :confused:. I knew I wasn’t going to be able to repair it myself so I returned them.
I now have the Liberty 4. Unfortunately, I’ve lost the ability to independently test each ear for frequency variations, even though it’s using the same SoundCore app. Obviously, they have independent firmwares and therefore independent :wink: features. I’m bummed because the Liberty 3 Pro had the firmware I preferred :confused: :pensive:.
I would suggest you try forgetting the connection and reconnect to see if that works. But if it still changes nothing, I would suggest you return them immediately, if still under warranty. Good luck :+1:.

I had the exact problem and the only thing that worked at the end was leaving earbuds out of the case for 8 to 10 hour to extract their charge and then put them back in the charging case. This worked for me