Liberty 4 switching between devices issue

Hi everyone!
After 4+ month of zero problem with Liberty 4 earbuds,a few days ago I faced with an issue with switching my earbuds between my iphone and mac.

I have: iPhone 11, Macbook Air m1, Soundcore Liberty 4
Few days ago I noticed that headphones was being connected to my iphone, but didn’t play any sound. It was frustrating for a couple hours while I tried to fix it with different ways and it was fixed only by Liberty’s hard reset. Then I connected it to iphone and later to mac and it didn’t play sound on iphone as well. At the same time playing sounds form mac was ok! It repeated the same way - hard reset, new connection to iphone - all is ok, new connection to mac -> no sound on iphone.

In soundcore app Dual connection is ON and I haven’t ever seen this setting for that time I have been using Liberty 4, so I haven’t changed anything there.

As I understand, earbuds stopped switching to iphone and stucked being connected with mac, although iphone see it and think that it’s connected. All is okay if I don’t connect them to mac, but I need using it with both devices always.

Does anyone has the same problem?

3 Likes

Dual connection can make it so that it is connected to both your phone and another device at the same time. If this is turned on and there is sound coming from one device then sound can’t come from the other. I recommend turning off dual connections and trying on hi-res audio.

Hi, seems like you understand what is dual connection in wrong way. I didn’t say, that I expect to have a sound from one device while another device is producing a sound. I said that all worked fine for a long time: earbuds was connected to two devices at the same time, and when I started meeting on mac - it switched to mac; when I started playing music on iphone - it switched to phone. But now, even if my mac closed (sleep mode) and e.g. is in my backpack and I’m trying to playing music on iphone - phone shows that earbuds connected to it, but there is no sound through. When mac isn’t close to me, all works fine.

Hoping, I’ve explained clearly.

2 Likes

Ah I understand now. Im not sure why that’s happening. Best advice I can give is to unpair(not disconnect) from both devices and then repair them. Making sure that firmware is up to date is probably also a good idea.

I have the same issue. When connected to both my Android phone and Macbook pro using Dual connection mode on my Liberty 4 earphones, I can get sound from the Macbook but not from my phone.

If I go to the Dual Connections option on the soundcore app and disconnect my Macbook the sound works on my phone again. I don’t ever have to disconnect the phone to get the Macbook sound to work

Also the Macbook will reconnect at times since I don’t actually turn dual connections off and the sound from my phone immediately stops.

I suspect something on macOS might causing this issue. This feature worked perfectly a few months ago, only thing that has changed since was an update to macOS.

Anyway I haven’t found a permanent fix for this yet.

1 Like

Hey everyone,

I’ve been dealing with a similar issue on my Mac Pro and Android phone with Liberty 4 NC. even when there’s NO audio playing on my Mac, the sound on my Android phone is still absent. It seems like the Mac always takes precedence in the connection, and switching between devices becomes impossible. I’ve tried unpairing and repairing, but the problem persists. Has anyone found a solution to this? It’s becoming quite frustrating.

Thanks!

Hi all,

I’m having the exact same issue. Multipoint connection seems to be stuck once the earbuds are connected to my MacBook Pro. They won’t switch to my phone when playing music or watching a video, any media at all. It will only work by manually switching your audio on the MacBook to speakers instead of the Liberty 4 NC’s. Would be great if this issue could be solved…

I have these earbuds only for three days now and had to do more research/investigation than listening music. :see_no_evil:

Same thing here. The multipoint connection mode seldom works well almost on all buds that I use. With Liberty 4 when multipoint is turned off my laptop always took precedence over Android phone. Possibly last-connected device autoconnect function, signal strength or BT chip generation of each device.
In any case if you have congested BT airwaves in your environment and have multiple devices paired to your buds issues are bound to pop up.

Hello everyone,
I am currently experiencing a similar issue on my Liberty 4 NC’s. Essentially, when I pause media playback on my phone (Android), the audio from my laptop (W11) takes over within seconds. However, when I resume playback on my phone and pause the laptop’s media, it takes a good 15 seconds for the phone’s audio to become audible again. I’ve got this problem after updating to 04.86, before that everything worked absolutely fine. Anything to fix this?
As I have read similar issues on this thread, I wonder if this !5 seconds delay that I get, is happening to everyone? Or do you guys get no media playback from your phone even after waiting for 15 seconds or so?

Same issue on my liberty 4 NC when connecting to a MacBook pro.
I notice that if I close the window that has sound it changes to the phone.
The bigger issue is on the evening when the MacBook is suspended and I’m not there to close the window.
Please fix this

Same issue here, it was incredibly frustrating. I ended up finding two semi-fixes for it:

  • Dumb way: go into the Soundcore app and manually disconnect the earbuds from the computer. Like others here, this often happens when my computer isn’t easily accessible (closed in a backpack or something), so at least being able to manually resolve the issue from my phone is nice.
  • Actual way: I don’t think this is actually a Soundcore issue, it’s a Mac one. There’s probably some app on your computer that has an active connection to the audio output, even if it’s not playing music. For me, quitting Zoom fixed my problem here; it must have maintained some active audio output stream even after I quit my last meeting.

@Soundcore: a fix to this might be showing the name of the audio feed for each connected device (i.e. Spotify, Zoom, Chrome, etc) in the app. Knowing that it was, in my case, Zoom would have saved me a ton of headache; I was about to return the earbuds because of this.

Hope this helps other folks!

I have the same problem with samsung S21 Ultra and Macbook Pro. Please fix it!!!

Same issue for me. MacBook Pro M3 and Pixel 8 Pro. If the MacBook is powered on I get no sound from my Pixel. This was not a problem on my previous ThinkPad.

I think it might be the way MacOS is managing conferencing apps. If I close WebEx the problem seems to resolve.

Edit: Nope, it’s not WebEx, it’s just MacOS dominating the connection. I have to use the Soundcore Android app to disconnect the Macbook before I can play any sound from Android.

Hello
I have question since you are using Liberty 4 with your MacBook Air M1. Did you notice any sound skipping issue or stuttering issues while listening music on MacBook Air M1 via Liberty 4?
Thanks

Same issue here with a Macbook Pro M3 chip. I have both Teams and Slack running on it so I will try closing each of those and see if either of them are contributing to the problem.