Liberty Air doesn't do anything

I have just purchased a Soundcore Liberty Air.
I unwrapped it, opened the case, removed the plastic from both buds, put them back and charged until the case shown full 3 dots.

After I took them out but they don’t do anything. None of my devices recognize it, I tried to turn them on manually but nothing. The buds don’t do literally anything, they never flashed for anything regardless how many times I pressed the touch side, they are not responding to reset them with the case either nothing…

Any suggestion what am I supposed to do?


Leave buds in case, plug case into power overnight.


Try again all the things you just tried, so reset buds in the case, but with the power still connected to the case. Then take buds out and see what happens.

If still dead then probably you should initiate warranty with the vendor. I hope you didn’t buy from AliExpress…

Thanks for the suggestion, will try this to see what happens.
I bought it locally so I can send it back at least.

Good luck.

The Liberty Air was released spring 2019, over 2 years ago. So there’s a chance of old stock the batteries either dead or needing more persuasion to get back to life.

If charging doesn’t end up working, I’d just return it. Good luck!

1 Like