Liberty Pro 3 - Multipoint conflict issue during calls (between phone & laptop)

LP3 connected to phone & laptop, when making phone calls the buds will work for about 2 seconds and then it seems that it will be forced to connect to the laptop.

on the phone call i’m able to select blue-tooth mode (from phone/speaker) and i can get audio (mic wont work) for about 2 seconds and then switch back to connecting to laptop.

I have to go into the app > more settings > device list > disable connection to laptop in order to make sure i can continue using buds for my phone call.

Anyone else getting this and is there a way to fix it without having to disable the connection to laptop? If i have to do this, kinda defeats the purpose of multipoint connection.

To be simple, you will need to unpair both devices. Pair the laptop first and then the phone. I think it was the older BT will conflict with newer one as stated in several threads here.

2 Likes

New update just annouced. Hope it will solve the issue.

1 Like

There are two issues in the scenario you describe.

The buds can connect to two devices concurrently but cannot swap from a newer to older bluetooth. The switching is only seamless when devices are same bluetooth versions.

Bluetooth profiles are headset and headphone, microphone is attached to the headset profile.

Windows tends to want to try to reconnect to anything paired.

So you get a tidal friction between the phone trying to connect the headset profile and then the Windows system fights to get it back. Depending which connected first if the laptop did (usually BT 4.2) then the phone can connect and the laptop can connet, but not the other way round.

Workaround would be to get to an end state your phone is only paired for calls only and laptop for media only. You can try to get it towards this end state by delete all pairings, then pair with laptop and then delete the headset profile, then pair with phone.

I think your issue is similar to mine. Connected to my laptop and phone simultaneously, I can go back and forth with no problem until I get a phone call. They both still show connected to the earbuds, but I lose audio on laptop and phone. I have to place the earbuds back in case, turn on of bt on both devices then back on and then reconnect to both. Very frustrating…I have the Jabra Elite 75t’s and the multipoint is seamless and I’ve never had any issues.

1 Like

I’d be curious if this were still true when the laptop and phone are on the same Bluetooth version.

Regardless, its a bug. Email service@soundcore.com to let them know so it can be worked on in next release.

Don’t you think it highly odd they have beta testing and reviews and mentioned multipoint but something this trivially common failed to be spotted?

Have done this, work well in the beginning.
But, after I disconnect from phone and connect to laptop, the problem persists and no sound at all on my laptop (Thinkpad L390).

I don’t own these products so I’m guessing. But try this:

  • Laptop bluetooth off, phone bluetooth off, buds in case (off).
  • Phone bluetooth off, take buds out of case and connect to phone.
  • Go to phone bluetooth settings the connected buds, and disable media so it’s only phone calls and contact sharing (this means it’s only connecting using headset profile).
  • Disconnect from phone, phone bluetooth off, buds back in case.
  • Laptop bluetooth on, connect to laptop as headphone profile.
  • Phone bluetooth on, connect to phone.
  • Play some laptop media.
  • Make your phone get incoming call (e.g. ring it from another phone), see if works, then hang up
  • See if laptop media resumes playing.

Let us know if works or doesn’t work, it’s handy to collect known to not work or known to work methods.

If it works I’ll explain what I think is happening.

Hi thanks for reaching out Prof.

Tried all the process, they all worked fine until these steps:

  • Make your phone get incoming call (e.g. ring it from another phone), see if works, then hang up
  • See if laptop media resumes playing.

After that, boom, all sound just vanish from my laptop.

Kindly advise me what to do next. Thank you.

p.s: even after I turn off all bluetooth (phone off, laptop off, buds in case) and then try to only connect buds to laptop, still no sound at all on laptop.
p.s.s: after the “incident”, my buds won’t play any sound at all on my laptop, no matter if I disconnect or turn off/on laptop BT. ONLY if I reset (press pairing button for 10s) that my buds can play sound again on my laptop.

Make sure you have emailed support and opened a ticket, the more who do that the more attention it gets and the faster to the fix. If you get a fix then please share.

I see your laptop is BT 5.0

What phone do you have?

So this is such a trivial thing, a phone and a laptop, it’s unbelievable it never got tested, or a bug fixed, by now the product was in beta for months. So I’m thinking you somehow are a rare combination of hardware and/or settings which has found a fresh bug. e.g. some particular chipset in laptop. This is why all issues have to be causing a support ticket if we can’t fix quickly amongh peers.

Thanks Prof, I have already created ticket to Soundcore Support.
Hopefully they’ll release a firmware update soon.

My phone is Galaxy S21 5G, which surprisingly, also BT 5.0 (the same BT version with my Thinkpad L390).
So, I think the BT connectivity issue with L3P also affect devices (phone/laptop) with same BT version.

1 Like

https://www.google.com/search?channel=fs&q=galaxy+s21+bluetooth+issues

Seems there’s a lot of Samsung S21 bluetooth issues. Some of the tips and fixes I suggested already, others you could try.

Either - everyone has this issue as it’s the LP3 fault, or only Samsung S21 has it so Samsung fault.

I’d nose around in the above for ideas. One tip more than wipe bluetooth cache is to wipe bluetooth data and pair everything again. Another is in Auto sync, another is “Try turning on ( turn off A2dp hardware offload ) in developer options”.