Life Q30 Problems and Bugs

First of all, I just wanna say that I’ve had about 5 pairs of Soundcore headphones so far, and never had any kind of technical problems with them.

Unfortunately, it’s not the case with the Life Q30. I’ve had them for about 2 months, and I’m beyond frustrated.

First of all, there’s a weird lagging issue that happens while watching videos, and the only way to solve it is to reset the headphones. So I found myself resetting them several times a day, and I was willing to live with it because I really love the Transparency mode.

But now I just turned them on as usual, put them on, and… Found that the left side of the headphones is completely dead. No sound, no change when switching between the modes.

I doubt there’s anything I can do at this point, but if anyone has any kind of suggestion, I’d love to hear it.

If the headphones are still covered by the warranty, you should contact the support asap.
Don’t forget to add all numbers you find on the headphones (package), and remember there is no support over the weekend.
A little bit of patience is needed.

Agree…

It is probably the best to contact support. As long as you have had it less than 18 months and have documentation that it was bought then you should be good for the warranty. (Usually bought online such as Walmart, or Amazon will have your order history)

I’d also recommend you Contact Customer Support. Good luck!

Left side died on my 2nd unit, got a replacement next day told to discard the dud unit.

Use your warranty!

Hopefully you kept / have proof of purchase and you didn’t get from AliExpress…

Latency, I’m thinking you have it connected to two things at once, even unwittingly.

I will join the other in suggesting to contact customer support. You can use email service@soundcore.com for this

Hi, @TheArtOfLoss I am sorry to learn about the issue with your Life Q30, in this case, the following tips are worth trying:

  • Use the headphones to listen to the downloaded music or video on the phone to see whether the issue still persists.
  • Try deleting the pairing history on your device, resetting your device, then try to pair with the headphones again (reset the headphones.)
  • Try pairing the Soundcore headphones with another Bluetooth device.

If the issue still persists, please drop an email to service@soundcore.com detailing the issue and the order information, our Soundcore technical support team will take care of your case within 24hrs.