Q20 not charging

I have a pair of Q20s that I bought in November 2020. I have only needed to charge them twice since then as I don’t use them often. A couple of days ago I tried to charge them again. When I plug them in, the light flashes red ONCE and goes out. They were on the charger for 6 hours and refuse to get any higher than “Battery low” when announcing the level. I’ve tried other cables and chargers that work on other devices.

Any suggestions?

Probably a dud by the sound of it but the only thing to try you not mentioned is a reset.

I’d also get a flashlight and a magnifying glass and look for debris in the port, sometimes debris gets pushed in each time you push cable in and eventually interferes with charging.

Did you try a reset?

If none of the above suggestions solve your problem, I would suggest contacting Customer Support since they should still be under warranty (18 months).

I have a similar issue - can you provide advice on how to reset the unit?

If you use the magnifier function in the left upper corner you may find
a “how to”.

1 Like

I’m having the same problem. To reset, it says to hold power and vol+ while charging, but how do you do that if you can’t charge?

Did anyone else find a fix?

1 Like

I had exactly the same problem and was able to fix it with the instructions here:


A little disassembly required to remove a component, under 5 mins total time.

Hello, i also have a problem with charging. Even if I charge it overnight it stills tell me that the battery is low. But the difference is that the red light is present

shut up u dumb as$ niggq