Q30 dosen't work with bluetooth 5.0

I’m trying to connect my Life q30 to my computer. I have a 5.0 bluetooth adapter and I can use it with my jbl soundbar and a edifier headset (w800bt). It stays connected for secs and suddenly gone. There is no driver update for both, adapter and headphone in windows update, or any warning about issues in device manager. It worked with another 4.0 adapter on the same computer, the problem appear only with Q30 when I changed for a 5.0 one. I tryied to unistall bluetooth and Q30 drivers from de computer.
Q30 firmware: 02.30
Windows 10 latest update
Captura%20de%20tela%202021-06-04%20172912 Captura%20de%20tela%202021-06-04%20173150 Captura%20de%20tela%202021-06-04%20173205 Captura%20de%20tela%202021-06-04%20173238 Captura%20de%20tela%202021-06-04%20173251 Capturar

The Q30 cannot connect to newer then older versions of Bluetooth without a reboot.

First make a clean slate.

Delete all pairings. You need to concentrate and remember all pairings as often folks have played with different devices.
Turn Bluetooth off of all paired devices as some don’t actually forget pairings, including the PC. Don’t even go down the “but I shouldn’t need to…” logic trap.
Reset the Q30.

Now with a clean slate.

Turn PC Bluetooth back on, Pair with PC.

It should now work. If doesn’t then it’s a driver or settings issue. Assuming working now.

If you want to use with other devices then one off:

Turn off Bluetooth on the PC.
Turn headphones off, then on.
Pair with other device (e.g. phone).

Once you have it working with each device then follow either:

  • connect to the oldest Bluetooth version first.
  • connect to newer Bluetooth version next. This is what I do once I got it working with each device.

Or: turn headphones off then on, sometimes you have to do this to fix if you connected to newer then older versions.

Hi @The_Professor, thank you for replying. I tried to reset the Q30, I also reset bluetooth drives and did your steps, but dosen’t work :confused:
The computer recognized Q30, install the bluetooth and audio drivers, but after disconnect and don’t reconnect.

You utterly 100% sure you don’t have any other Bluetooth devices (phones etc) paired in the mix?

I ask as there are “oops I’d forgotten” replies here on this topic.

I challenge you to try all the steps and not think you have them covered.

You mentioned having 4.2 and 5, the 4.2 isnt fighting the 5 ?

So, what i did

  1. unistall bluetooth drivers
  2. remove bluetooth adapter from computer (I had already removed the 4.0 before I started having the problem)
  3. turn off phone bt
  4. reset q30
  5. restart pc and reinstall drivers
  6. finally, pair the headphone

I’m sure about bt devices, i only have my phone. I can try again to be sure, but i swear i did everything correct

I just saw it


Look how the system “see” different the two devices