Q30 Microphone on phone calls

I recently purchased the Q30. I think the headphones are great for listening to music, but I have had issues with phone calls. The person on the other end can hear everything going on in the room. It is like I have transparency turned on for the person on the other end of the line. My wife will not even talk to me since she can hear every whisper in my office crystal clear. Is there any setting that I am missing to fix this?


Hey there, here are some tips for your reference.

  1. “Forget” the headphones in your device’s Bluetooth history, and reset the headphones by holding down MFB(power button) and volume + button for 5 seconds, and then pair them again.
  2. Make sure you are wearing the headphones correctly to ensure the microphone is facing towards your mouth. There is an L/R logo inside the ear pad.
  3. Upgrade the firmware to date via Soundcore App

If it doesn’t work, please tell us the name and version of the APP if you are using a calling APP instead of the default phone call on your device. Or just drop an email to service@soundcore.com and we’ll see what we can do for you.

1 Like

I did a test with the Q30 and the Q20… On Phone calls with the TV playing on my side. With the Q20s the other person could NOT hear anything other than me. With the Q30s the other person could hear EVERYTHING, Myself and the TV.
It was Night and Day between the 2 headsets… I did try the Q30s several times, all came with the same conclusion… Basically no ANC.

Same here. I did the reset. My wife told me she could finally not hear everything going on around me. However, when I did a test and turned on transparency, all of a sudden she could hear forklift horns that were so far away I could only hear them in transparency mode. When I changed back to normal, she could still hear them but I could not. So it looks like the only way I can make it work is to do a total reset and never change the mode from normal.

I did read some older review that stated the same problem with the Q30, but they said it was fixed in 1.8. My headset is on 1.90. Possible the problem returned?

Do not have but what kind of phone do you have? Have you done a search in the community, I could have swore that there has been some comments on here.

Not disagreeing, just challenging the terms.

ANC Active Noise Cancellation is piping anti-noise merged in whatever sound you want to hear to the ear. That does involve microphones, usually near the ear and a couple outside.

Noise isolation, also often called ANC, is not to cancel what you hear, but what the other end hears from you. These require a mix of ignoring frequencies not central to typical human voice, using left/right microphones to ignore sounds not central (mouth is mid-way between ears), and ignoring aft noises using fore/aft microphones. So frequency filter and 4 microphones minimum.

So what I’m inferring is the Q20 has the latter, the Q30 doesn’t.

There’s enough microphones in the Q30 to do a better job, if they wanted to.

That implies the Q30 can do better, and it’s a bug they not fixed.

The point has been known about for months, plenty of time to tune the issue, if not fixed by now… looks unlikely…

1 Like

Still not fixed. I am on Firmware version 2.3 right now. Any news ?

I would contact service@soundcore.com to check on any fix that can be done. Unless you mention it they may not know that it is an issue.

Is there anything new? The error is still present with me.
Firmware version 3.50

The problem still persists, I have the firm 3.50 and I can not speak in any meeting with a little noise, they hear even the footsteps.

They are not functional.

El problema sigue persistiendo, tengo el firm 3.50 y no puedo hablar en ninguna reuniĂłn con un poco de ruido, escuchan hasta los pasos

No son funcionales.

1 Like

I found the issue on my end, I was experiencing the same problem so when this headset was connected to my Windows laptop, it was picking up all the background noise around me as well during calls. I went into “Devices and Printers” in Windows, then right click the “Soundcore Q30” device and select “Sound settings”. In the window that pops up, I went to “Recording”. I could see the Soundcore Q30 headset was enabled so all good, but the “Microphone Array” was also enabled. So I suspect that Windows was picking up both the input from the Q30 and the input from the laptop’s microphone array. I then disabled the Microphone Array device in that same window and boom, problem solved!

I hope this helps others as well.

You were lucky as it never worked for me :frowning:

Same problem here…
the microphone captures all my teammates noise in a videocall…

firmware version 3.50… there are no firmware updates in the last 3 years? seriously?