Right earbud for spirit x2 not turning on and not charging

Alright here is my issue that I have to share,

I bought the Soundcore spirit X2 earbuds like at least a week ago, they were amazing. Than just the right earbud stopped working out of no where, and I need help trying to figure out what’s wrong with it.

Could be a few reasons. The first thing to try is clean the buds and case with isopropyl alcohol and check for debris on buds and in case.
Next reason is they or the phone simply got confused, for various reasons, so delete pairings and reset buds.

If neither of these work then delve deeper into less common causes.

Before you reach out to service, here are a few things that you could check… okay it’s more than a few… :roll_eyes:

  • check contacts on the earbuds, clean if necessary

  • check contacts in the case, maybe one of the pins is sticky

  • when you put them in the case and close the lid, does the case lights, light up on both ends (assuming it has 3 on the front)?

  • does the case take a charge? Is it fully charged.

  • did you charge every thing before you started using?

  • have you tried connecting to another device? If so, it may be connected to that second device… a reset may be necessary, and go through the pairing process again.

A quick how to vid…

If all of the above fails to resolve, with your notes of what was tried, can be bundled up in an email to service. Make sure to note where purchased and when.

Best of luck, and hope all works out for you.


Outstanding tips :clap:.
Have you not thought about working at Soundcore :smiley:?

1 Like

Awesome tips. I need to bookmark these. These are the same steps I use to reset my various different TWS earbuds.

1 Like

I’m back and tried the alcohol sadly nothing happened, and only the left bud has been working fine, I deleted the pairing, but when trying to reset them, yet again the left bud is the only one flashing. Only this is what comes up. it’s been fully charged, and there’s nothing wrong with the pins. Yes I charged everything before I started using them, and lastly when trying to connect on a different device only this comes up.

I’m sincerely sorry for the very late response, been busy today, so couldn’t get back to y’all, hope y’all have a great weekend.

1 Like

I don’t own these specific buds, you know more than me.

But I’d suggest these additional ideas:

  • the reset instructions, it sometimes help if you wait a minute or so between each step. I’ve seen some bud resets (not yours, other models) the user said they realised they were rushing and waiting was the trick.
  • keep the case connected to power while you follow the reset instruction.

Ultimately if common fixes don’t work then the final step is to write up all you’ve tried and email support.

1 Like