Voice messages use internal mic instead Liberty 3 Pro

I have Soundcore Liberty 3 Pro and an Samsung S8 phone. When recording a voice message via WhatsApp, Signal or Telegram, the phones internal mic is being used… (in Bluetooth settings, call and media audio is activated).

You already answered what I was thinking it could be. I do not have the 3s or WhatsApp. Have you checked that apps settings to see if you have to give permissions to use mic or something like that? Or maybe to check within the app to see if it may have a setting to which mic to use.

You should check all your adjustments (phone and buds).
I am sure there is one which is not activated.

I tried to toggle all the options, but it did not help.

The only thing I know that Samsung has a very “special” type of Android OS installed.
May be other members who got such a phone can give you more help.
Good luck.

I don’t own either of these products but I’ve seen folks with Samsung+Soundcore get success when they did “A2DP offload engine,” toggle. Search how, think it’s lurking in developer mode settings. Search.

That does not seem to work on the S8 phone.

I suggest to contact supoort by email service@soundcore.com