My app on android cant find my Liberty 3 Pro

When I try to connect my new Liberty 3 Pro the app cant find them and sais not supported app version 2.8.2
I have tried to reinstalled I use a Samsung Galaxy S20 Ultra, The app dont support the new 3 pro but they work without the app but only use AAC. There is now newer app version when i check in google store.

1 Like

Ohh and I still have my Liberty Pro 2 in the app but i have disconnected them in bluetoth settings so they dont interfer

I am on the same version. L3P is available on app

I tested on my win 10 pc and there i can se the Liberty 3 Pro in the list but not in my phone app wich is strange same app version in phone and pc

Not on my list sadley

1 Like

Strange issue. I would suggest to contact customer support by email

LOL I had to factory reset my phone for it to work after I had tried eraese apps and secure unistall apps …

.I had the same problem 3 days ago.
@stratoz99 You probably have the 2.8.2 update on September 22nd.
I didn’t have Liberty 3 Pro in this update. After three days, while doing the Q35 update, I suddenly saw that I had the 2.8.2 update but dated October 9th. Liberty 3 Pro is out there. The problem fixed itself. :slightly_smiling_face:
Maybe not all regions of the world get updates at the same time. I am from Poland and I got it yesterday.

Strange indeed – definitely was available in 2.8.1 also …
If you have a lower version you can try manually installing a new one

On Android 10 (LG G8) they were on both v2.8.1 and v2.8.2 of the Soundcore App. I’m in the USA if that’s relevant.

I may be wrong on what I am thinking.

They stated that they can not see it in the app but then talk about testing it in the win 10 pc and can see it in that list.

So I think you can see them in the BT part of the pc, and you can see them in the BT on the phone as you got them connected but you can not see them in the BT from the app.

I would update the app first. Retry to add the earbuds through the app.

In case you need help with the BT through the app.

I would then contact after that.

Was not showing on Galaxy Note 10+5G. V2.8.2 so called Anker CS and was told to un and re install - no joy still nothing. Does show up an iPhone version of the app so able to get everything up and running. Afterward still nothing on Android - I was logged in to my account with my L2Pros showing. I logged out, connected the L3Pros and clicked to add manually and now they were on the list. Hope this helps someone else.

iPhone version didn’t offer any LDAC options but the Android version does.

1 Like

Yes unfortunately us iOS users don’t get the joys of LdAC as apfel doesn’t think it would be of benefit…

Granted mine ears likely couldn’t tell the diff beyond 192kbit…