Q30 and Galaxy S20+

Unable to use Q30s with Galaxy S20+. This is my second pair, phone says paired but they won’t connect. App is 100% useless, bt settings say app is needed to use headphones. Can connect headphones, without app, toy Oneplus with no issues. Any ideas?

Try deleting the device from your bluetooth settings. Next reset the headphones and try reconnecting them.

It is a two part connection.

  1. You connect the headphones to your phone.
  2. You go into the app, go to headphones and find the headset and then you basically pair them to the app. Once that is done, you can can access the q30 in the app.

So the only problem with all that is that I’ve already done all this. But, I did it again and now, just like on the first set of headphones, I get a message that the headphones need an app to use them. This happens on 2 different Galaxy phones. But it connects to a much older phone, without the app.

1 Like

I know people have not done that sometimes and just making sure.

My only other thoughts at the moment is to try to reinstall the app as I know that has resolved some issues as well.

I tried that 3 times just now, still not connecting. It pairs with the phone, just won’t connect.